summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/librttopo/librttopo-1.1.0.ebuild')
-rw-r--r--sci-geosciences/librttopo/librttopo-1.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-geosciences/librttopo/librttopo-1.1.0.ebuild b/sci-geosciences/librttopo/librttopo-1.1.0.ebuild
new file mode 100644
index 000000000000..09e3dd82391a
--- /dev/null
+++ b/sci-geosciences/librttopo/librttopo-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Exposes an API to create and manage standard (ISO 13249 aka SQL/MM) topologies"
+HOMEPAGE="https://git.osgeo.org/gitea/rttopo/librttopo"
+SRC_URI="https://git.osgeo.org/gitea/rttopo/librttopo/archive/${P}.tar.gz"
+S="${WORKDIR}/librttopo"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="sci-libs/geos"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}