summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/xyzservices/xyzservices-2023.10.1.ebuild')
-rw-r--r--sci-geosciences/xyzservices/xyzservices-2023.10.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-geosciences/xyzservices/xyzservices-2023.10.1.ebuild b/sci-geosciences/xyzservices/xyzservices-2023.10.1.ebuild
new file mode 100644
index 000000000000..227f2c211f96
--- /dev/null
+++ b/sci-geosciences/xyzservices/xyzservices-2023.10.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="Source of XYZ tiles providers"
+HOMEPAGE="https://github.com/geopandas/xyzservices"
+SRC_URI="https://github.com/geopandas/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/setuptools-scm"
+
+# Need mercantile module
+# distutils_enable_tests pytest