summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/laszip/Manifest1
-rw-r--r--sci-geosciences/laszip/files/laszip-2.2.0_fix-build-system.patch50
-rw-r--r--sci-geosciences/laszip/laszip-2.2.0.ebuild27
-rw-r--r--sci-geosciences/laszip/metadata.xml15
4 files changed, 93 insertions, 0 deletions
diff --git a/sci-geosciences/laszip/Manifest b/sci-geosciences/laszip/Manifest
new file mode 100644
index 000000000000..b349f05ee4c2
--- /dev/null
+++ b/sci-geosciences/laszip/Manifest
@@ -0,0 +1 @@
+DIST laszip-src-2.2.0.tar.gz 407457 SHA256 d0f6fa9c486caa6905927ebf32240aa7ef34181bbcc039cf8e51aa923557dc79 SHA512 44dacb0d0ab79ac02c784549f42c4522451646b322835afc78fbf8bb82be40e023d374635c2a18989c73a5553e05b55d7c32f35d510f816704020b0e02365824 WHIRLPOOL 4454e60c4e21f2f163e3ca4a8deefce5a42c1f7b7549eb736c51c89d4a8f05d0a57aad194a84c45aff34be8c14eac1d0d61d983611d6abba7cb85d4c2dc83247
diff --git a/sci-geosciences/laszip/files/laszip-2.2.0_fix-build-system.patch b/sci-geosciences/laszip/files/laszip-2.2.0_fix-build-system.patch
new file mode 100644
index 000000000000..4587331eba3f
--- /dev/null
+++ b/sci-geosciences/laszip/files/laszip-2.2.0_fix-build-system.patch
@@ -0,0 +1,50 @@
+--- laszip-src-2.2.0/configure.ac
++++ laszip-src-2.2.0/configure.ac
+@@ -21,9 +21,6 @@
+
+ m4_define([debug_default],[no])
+
+-CFLAGS="-Wall -Wno-long-long -pedantic $CFLAGS"
+-CXXFLAGS="-Wall -Wno-long-long -pedantic -std=c++98 $CXXFLAGS"
+-
+ dnl #########################################################################
+ dnl Checks for programs.
+ dnl #########################################################################
+@@ -68,8 +65,8 @@
+ CXXFLAGS="$CXXFLAGS -g -DDEBUG"
+ AC_MSG_RESULT(yes)
+ else
+- CFLAGS="$CFLAGS -O3 -DNDEBUG"
+- CXXFLAGS="$CXXFLAGS -O3 -DNDEBUG"
++ CFLAGS="$CFLAGS -DNDEBUG"
++ CXXFLAGS="$CXXFLAGS -DNDEBUG"
+ AC_MSG_RESULT(no)
+ fi
+
+--- laszip-src-2.2.0/src/Makefile.am
++++ laszip-src-2.2.0/src/Makefile.am
+@@ -1,6 +1,6 @@
+ SUBDIRS = .
+
+-AM_CPPFLAGS = -I. -I../include -I../include/laszip
++AM_CPPFLAGS = -I. -I$(top_srcdir)/include -I$(top_srcdir)/include/laszip
+ noinst_LTLIBRARIES = liblibrary.la
+
+ liblibrary_la_SOURCES = arithmeticmodel.cpp \
+--- laszip-src-2.2.0/tools/Makefile.am
++++ laszip-src-2.2.0/tools/Makefile.am
+@@ -1,5 +1,5 @@
+
+-AM_CPPFLAGS = -I../include -I../include/laszip
++AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/include/laszip
+ LDADD = ../liblaszip.la
+
+ laszippertest_SOURCES = laszippertest.cpp
+--- laszip-src-2.2.0/include/laszip/Makefile.am
++++ laszip-src-2.2.0/include/laszip/Makefile.am
+@@ -1,4 +1,4 @@
+-laszipdir = $(includedir)/
++laszipdir = $(includedir)/laszip/
+
+ laszip_HEADERS = lasunzipper.hpp \
+ laszip.hpp \
diff --git a/sci-geosciences/laszip/laszip-2.2.0.ebuild b/sci-geosciences/laszip/laszip-2.2.0.ebuild
new file mode 100644
index 000000000000..0003ae67553e
--- /dev/null
+++ b/sci-geosciences/laszip/laszip-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="Library for free and lossless compression of the LAS LiDAR format"
+HOMEPAGE="http://www.laszip.org/"
+SRC_URI="https://github.com/LASzip/LASzip/releases/download/v${PV}/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}_fix-build-system.patch
+)
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ autotools-utils_src_configure
+}
diff --git a/sci-geosciences/laszip/metadata.xml b/sci-geosciences/laszip/metadata.xml
new file mode 100644
index 000000000000..8f8bdb10ea21
--- /dev/null
+++ b/sci-geosciences/laszip/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>wraeth@wraeth.id.au</email>
+ <name>Sam Jorna</name>
+ <description>Proxy maintainer - assign bugs to him</description>
+ </maintainer>
+<longdescription lang="en">
+An open-source utility for compressing LAS-stored LiDAR information in a
+lossless format.
+</longdescription>
+</pkgmetadata>