summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/geocode-glib/Manifest1
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/Manifest b/sci-geosciences/geocode-glib/Manifest
index c5a78e3dcdec..3857821ba63a 100644
--- a/sci-geosciences/geocode-glib/Manifest
+++ b/sci-geosciences/geocode-glib/Manifest
@@ -1 +1,2 @@
DIST geocode-glib-3.26.1.tar.xz 75296 BLAKE2B 68e42868edfd73db94d16dcc754eea1ee736ad910c5180616ba351cc50b682cd3b7ea4a64c9e1296af315298f68ea850a1773c4a05955c1159a6038773aad184 SHA512 0eb8e8a668c3950d06e77a379d375e2297cf7d95435aa8212715ddc36c3a57a53192e75dd0c82a2f2e7e558ea0e903a477c9dfa54f8cd2805d048fe46265d621
+DIST geocode-glib-3.26.2.tar.xz 72956 BLAKE2B 40a32fb0ba61cd91b28e57c518dc5450ce89a16889a335d19fe722c1088a4cdb085237d1fe24d08eeac62581ac68895a7a2b432d66f46fc4e03466485cfe5060 SHA512 b3ef81fac6959f6c4725ca721125cdafbbec69233f321872e17f9035266ed7616018ef54a9082fbd0a83395d18c664144cfe3b431d63744be433f058071cd435
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild
new file mode 100644
index 000000000000..b194bf3c6a33
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/disable-installed-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test enable-installed-tests) # Actual installation to live system is sedded out, but we need this for running them in src_test
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ )
+ meson_src_configure
+}