summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/Shapely/Shapely-1.5.17-r1.ebuild')
-rw-r--r--sci-libs/Shapely/Shapely-1.5.17-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sci-libs/Shapely/Shapely-1.5.17-r1.ebuild b/sci-libs/Shapely/Shapely-1.5.17-r1.ebuild
deleted file mode 100644
index 692e04da131a..000000000000
--- a/sci-libs/Shapely/Shapely-1.5.17-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="https://pypi.org/project/Shapely/"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sci-libs/geos-3.3
- dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # fix install path for Cython definition file
- sed -i \
- -e "s|\(data_files.*\)'shapely'|\1'share/shapely'|" \
- setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}/lib" || die
- cp -r "${S}/tests" . || die
- py.test tests || die
-}