summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/arborx/arborx-1.2.ebuild')
-rw-r--r--sci-libs/arborx/arborx-1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/arborx/arborx-1.2.ebuild b/sci-libs/arborx/arborx-1.2.ebuild
new file mode 100644
index 000000000000..68330b8a5df7
--- /dev/null
+++ b/sci-libs/arborx/arborx-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library for performance portable algorithms for geometric search"
+HOMEPAGE="https://github.com/arborx/ArborX"
+
+SRC_URI="https://github.com/${PN}/ArborX/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="mpi"
+
+RDEPEND="dev-libs/boost:=
+ mpi? ( virtual/mpi[cxx] )
+ sci-libs/trilinos"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/ArborX-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DARBORX_ENABLE_MPI="$(usex mpi)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}