summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/arborx/arborx-1.4.1.ebuild')
-rw-r--r--sci-libs/arborx/arborx-1.4.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/sci-libs/arborx/arborx-1.4.1.ebuild b/sci-libs/arborx/arborx-1.4.1.ebuild
deleted file mode 100644
index c27f694b4071..000000000000
--- a/sci-libs/arborx/arborx-1.4.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Library for performance portable algorithms for geometric search"
-HOMEPAGE="https://github.com/arborx/ArborX"
-
-SRC_URI="https://github.com/${PN}/ArborX/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE="mpi"
-
-RDEPEND="dev-libs/boost:=
- mpi? ( virtual/mpi[cxx] )
- sci-libs/trilinos"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/ArborX-${PV}
-
-src_configure() {
- local mycmakeargs=(
- -DARBORX_ENABLE_MPI="$(usex mpi)"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-}