summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/arprec')
-rw-r--r--sci-libs/arprec/Manifest1
-rw-r--r--sci-libs/arprec/arprec-2.2.18.ebuild80
-rw-r--r--sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch13
-rw-r--r--sci-libs/arprec/files/arprec-2.2.18-gold.patch15
-rw-r--r--sci-libs/arprec/metadata.xml2
5 files changed, 1 insertions, 110 deletions
diff --git a/sci-libs/arprec/Manifest b/sci-libs/arprec/Manifest
index f3d410c98815..0a2b22bfcab1 100644
--- a/sci-libs/arprec/Manifest
+++ b/sci-libs/arprec/Manifest
@@ -1,2 +1 @@
-DIST arprec-2.2.18.tar.gz 1751743 BLAKE2B de9a9a37bbe03357ad17d9d10d8bb42f73b9c9464643a35d4d1e209d049c205f967266dcae1af8972fc8c029f03053b298a4c85fdc48fb3f66d152aca8623a25 SHA512 372eb0a0c3aceac0d222679058f47c4d1037b5a51524b752b87f1b61c1b25101c34d4e56d9da45b4075ea7040dd59a597e0add4f34be902955dcf209423a6579
DIST arprec-2.2.19.tar.gz 1962133 BLAKE2B a2fccc1908e791fd4759e61ff52b180fcaccbfbfa831ee1beca9b22a1a745d17d21040974ffe02ea21397a2339c819a30cd93a247738564a2b433f7cef14c9e4 SHA512 97cf090398aa169e31711077efd26dc6da1f62291ab37b241b133634838bdd44743f85b86b861a3be18d2696ae9132afb6cd1871502bedb9cc17dfb63fde2632
diff --git a/sci-libs/arprec/arprec-2.2.18.ebuild b/sci-libs/arprec/arprec-2.2.18.ebuild
deleted file mode 100644
index 8c4069fcd8da..000000000000
--- a/sci-libs/arprec/arprec-2.2.18.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD=90
-
-inherit autotools fortran-2
-
-DESCRIPTION="Arbitrary precision float arithmetics and functions"
-HOMEPAGE="https://crd-legacy.lbl.gov/~dhbailey/mpdist/"
-SRC_URI="https://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran qd static-libs"
-
-DEPEND="qd? ( sci-libs/qd[fortran=] )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.18-fix-c++14.patch
- "${FILESDIR}"/${P}-gold.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma) \
- $(use_enable fortran) \
- $(use_enable qd)
-}
-
-src_compile() {
- default
-
- if use fortran; then
- emake toolkit
- cd toolkit || die
- ./mathinit || die "mathinit failed"
- fi
-}
-
-src_install() {
- default
-
- if use fortran; then
- cd toolkit || die
-
- exeinto /usr/libexec/${PN}
- doexe mathtool
-
- insinto /usr/libexec/${PN}
- doins *.dat
-
- cat > mathtool.exe <<- _EOF_ || die
- #!/usr/bin/env sh
- cd "${EPREFIX}/usr/libexec/${PN}" && exec ./mathtool
- _EOF_
-
- newbin mathtool.exe mathtool
- newdoc README README.mathtool
- fi
-
- if ! use doc; then
- rm "${ED%/}"/usr/share/doc/${PF}/*.pdf || die
- fi
-
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
-}
diff --git a/sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch b/sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch
deleted file mode 100644
index 680e921d6807..000000000000
--- a/sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix compiling with C++14, due to changed operator T* -> operator bool semantics.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=593872
-
---- a/src/write.cpp
-+++ b/src/write.cpp
-@@ -196,6 +196,6 @@
-
- string str = to_string(precision, width, expn_width,
- fmt, showpos, uppercase, fill);
-- return (s << str) != 0;
-+ return static_cast<bool>(s << str);
- }
-
diff --git a/sci-libs/arprec/files/arprec-2.2.18-gold.patch b/sci-libs/arprec/files/arprec-2.2.18-gold.patch
deleted file mode 100644
index 293b495f10a7..000000000000
--- a/sci-libs/arprec/files/arprec-2.2.18-gold.patch
+++ /dev/null
@@ -1,15 +0,0 @@
- fortran/Makefile.am | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/fortran/Makefile.am b/fortran/Makefile.am
-index 8eb4d19..91a125c 100644
---- a/fortran/Makefile.am
-+++ b/fortran/Makefile.am
-@@ -4,6 +4,7 @@ LDADD = libarprec_f_main.la libarprecmod.la $(top_builddir)/src/libarprec.la $(F
-
- lib_LTLIBRARIES = libarprecmod.la libarprec_f_main.la
- libarprecmod_la_SOURCES = f_mp.cpp mp_mod.f mp_modm.f mp_modx.f
-+libarprecmod_la_LIBADD = $(top_builddir)/src/libarprec.la $(FCLIBS)
- libarprec_f_main_la_SOURCES = main.cpp
-
- if UPCASE_MODULE
diff --git a/sci-libs/arprec/metadata.xml b/sci-libs/arprec/metadata.xml
index 467aaebf1fbc..45204a1f3242 100644
--- a/sci-libs/arprec/metadata.xml
+++ b/sci-libs/arprec/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>