summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/buddy/buddy-2.4-r1.ebuild')
-rw-r--r--sci-libs/buddy/buddy-2.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/buddy/buddy-2.4-r1.ebuild b/sci-libs/buddy/buddy-2.4-r1.ebuild
new file mode 100644
index 000000000000..1bf0d298789c
--- /dev/null
+++ b/sci-libs/buddy/buddy-2.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit fortran-2
+
+DESCRIPTION="Binary Decision Diagram Package"
+HOMEPAGE="https://sourceforge.net/projects/buddy/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="buddy"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DOCS=( doc/tech.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gold.patch
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use doc && docinto ps && dodoc doc/*.ps
+
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r examples
+ fi
+}