summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild')
-rw-r--r--sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild b/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
index 92fefb044a1a..fa2a76ca48ac 100644
--- a/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
+++ b/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
@@ -48,15 +48,11 @@ PATCHES=(
)
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
use doc && python-any-r1_pkg_setup
}