summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cifparse-obj')
-rw-r--r--sci-libs/cifparse-obj/Manifest1
-rw-r--r--sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild54
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch16
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch110
-rw-r--r--sci-libs/cifparse-obj/metadata.xml8
5 files changed, 0 insertions, 189 deletions
diff --git a/sci-libs/cifparse-obj/Manifest b/sci-libs/cifparse-obj/Manifest
deleted file mode 100644
index b4e1510dc6e6..000000000000
--- a/sci-libs/cifparse-obj/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cifparse-obj-v7.105-prod-src.tar.gz 931151 BLAKE2B c362fc528e0c88b41ef8433c6d0235ae0bd4055c8c1704d2f1be8ba8aa27a7526b3d19172f2a4ffda79c323140a54dcb2b0a2eb78f30780473c9bcfb2ab6c6f9 SHA512 d626aa055bdd6762eda4b5b04121f37fff3bc09460b12cd6cb80566545d23e5c08a8ad54fa184076932d2cff38aa9d91fa659fbe9a70d4a07b8b1677c28549f4
diff --git a/sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild b/sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild
deleted file mode 100644
index 84c808a677e9..000000000000
--- a/sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-MY_P="${PN}-v${PV}-prod-src"
-
-DESCRIPTION="Provides an object-oriented application interface to information in mmCIF format"
-HOMEPAGE="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/index.html"
-SRC_URI="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/source/${MY_P}.tar.gz"
-
-LICENSE="PDB"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE=""
-
-RDEPEND=""
-DEPEND="
- app-alternatives/yacc
- app-alternatives/lex"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-makefile.patch
- "${FILESDIR}"/${PN}-7.025-gcc5_6.patch
-)
-
-src_prepare() {
- default
-
- sed \
- -e "s:^\(CC=\).*:\1$(tc-getCC):g" \
- -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
- -e "s:^\(F77=\).*:\1${FORTRANC}:g" \
- -e "s:^\(F77_LINKER=\).*:\1${FORTRANC}:g" \
- -e "s:-static::g" \
- -i "${S}"/etc/make.* || die "Failed to fix makefile"
-}
-
-src_compile() {
- # parallel make fails
- emake -j1 \
- C_OPT="${CFLAGS}" \
- CXX_OPT="${CXXFLAGS}"
-}
-
-src_install() {
- dolib.a lib/*
- insinto /usr/include/${PN}
- doins include/*
-}
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch
deleted file mode 100644
index 2ac0ec220d9e..000000000000
--- a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5_6.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- etc/platform.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/etc/platform.sh b/etc/platform.sh
-index ff0ab51..1b56ab1 100755
---- a/etc/platform.sh
-+++ b/etc/platform.sh
-@@ -60,7 +60,7 @@ case `uname -s` in
- # Check if it is a Linux platform
- Linux)
- # Check if it is GCC version 4.x
-- gcc_ver=`gcc --version | grep -e " 4\."`
-+ gcc_ver=`gcc --version | grep -e " [456]\."`
- if [[ -z $gcc_ver ]]
- then
- # It is not GCC version 4.x. Check if it is GCC version 3.x
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch
deleted file mode 100644
index 1716cd6390a4..000000000000
--- a/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch
+++ /dev/null
@@ -1,110 +0,0 @@
- etc/make.platform.gnu3 | 14 +++++++-------
- etc/make.platform.gnu4 | 16 ++++++++--------
- 2 files changed, 15 insertions(+), 15 deletions(-)
-
-diff --git a/etc/make.platform.gnu3 b/etc/make.platform.gnu3
-index 54b0297..138fa47 100644
---- a/etc/make.platform.gnu3
-+++ b/etc/make.platform.gnu3
-@@ -107,8 +107,8 @@ NON_ANSI_C_FLAG=
- C_WARNINGS=$(WARNINGS)
-
- # C compiler flags
--CFLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
--CFLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(C_WARNINGS) \
-+CFLAGS=$(C_OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
-+CFLAGS_NONANSI=$(C_OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(C_WARNINGS) \
- $(DEFINES) $(INCLUDES)
-
- ## C++ compiler
-@@ -128,14 +128,14 @@ C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
- EXT=C
-
- # C++ compiler flags
--C++FLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
-+C++FLAGS=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
- $(DEFINES) $(INCLUDES)
--C++FLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
-+C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
- $(C_PLUS_WARNINGS) $(DEFINES) $(INCLUDES)
-
- # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
- # source code that is not maintained by PDB
--C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
-+C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
- $(DEFINES) $(INCLUDES)
-
- ## Fortran compiler
-@@ -145,7 +145,7 @@ C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
- F77=f77
-
- # Fortran compiler flags
--FFLAGS=-O -u
-+FFLAGS=$(F_OPT)
-
- # Additional Fortran libraries
- F77LIBS=
-@@ -158,7 +158,7 @@ F77LIBS=
- STATIC_LINKING=-static
-
- # Linker flags
--LDFLAGS=$(ABI) -w $(STATIC_LINKING)
-+LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
- LDFLAGS_NO_STATIC=$(ABI) -w
-
- # Fortran linker
-diff --git a/etc/make.platform.gnu4 b/etc/make.platform.gnu4
-index 6676f35..51681fa 100644
---- a/etc/make.platform.gnu4
-+++ b/etc/make.platform.gnu4
-@@ -107,11 +107,11 @@ NON_ANSI_C_FLAG=
- C_WARNINGS=$(WARNINGS)
-
- # C compiler flags
--CFLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
--CFLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(DEFINES) $(INCLUDES)
-+CFLAGS=$(C_OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
-+CFLAGS_NONANSI=$(C_OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(DEFINES) $(INCLUDES)
-
- ## C++ compiler
--## This part defines C++ compiler information
-+
-
- # C++ compiler executable
- CCC=g++
-@@ -127,14 +127,14 @@ C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
- EXT=C
-
- # C++ compiler flags
--C++FLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
-+C++FLAGS=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
- $(DEFINES) $(INCLUDES)
--C++FLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
-+C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
- $(C_PLUS_WARNINGS) $(DEFINES) $(INCLUDES)
-
- # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
- # source code that is not maintained by PDB
--C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
-+C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
- $(DEFINES) $(INCLUDES)
-
- ## Fortran compiler
-@@ -144,7 +144,7 @@ C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
- F77=f77
-
- # Fortran compiler flags
--FFLAGS=-O -u
-+FFLAGS=$(F_OPT)
-
- # Additional Fortran libraries
- F77LIBS=
-@@ -157,7 +157,7 @@ F77LIBS=
- STATIC_LINKING=-static
-
- # Linker flags
--LDFLAGS=$(ABI) -w $(STATIC_LINKING)
-+LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
- LDFLAGS_NO_STATIC=$(ABI) -w
-
- # Fortran linker
diff --git a/sci-libs/cifparse-obj/metadata.xml b/sci-libs/cifparse-obj/metadata.xml
deleted file mode 100644
index e490bcb8aa87..000000000000
--- a/sci-libs/cifparse-obj/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
-</pkgmetadata>