summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/fftw/fftw-9999.ebuild')
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild34
1 files changed, 14 insertions, 20 deletions
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index 718aed13b25a..9266b28d174d 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=6
FORTRAN_NEEDED=fortran
-inherit flag-o-matic fortran-2 toolchain-funcs versionator multibuild multilib-minimal
+inherit flag-o-matic fortran-2 multibuild multilib-minimal toolchain-funcs
DESCRIPTION="Fast C library for the Discrete Fourier Transform"
HOMEPAGE="http://www.fftw.org/"
@@ -17,25 +17,22 @@ if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
else
SRC_URI="http://www.fftw.org/${PN}-${PV/_p/-pl}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
fi
LICENSE="GPL-2+"
SLOT="3.0/3"
-IUSE="cpu_flags_ppc_altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
+IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
RESTRICT="!test? ( test )"
RDEPEND="
mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
+ quad? ( sys-devel/gcc[fortran] )
test? ( dev-lang/perl )"
-if [[ ${PV} = *9999 ]]; then
- DEPEND="${DEPEND}
- dev-ml/ocamlbuild
- doc? ( media-gfx/transfig )"
-fi
S=${WORKDIR}/${MY_P}
+HTML_DOCS=( doc/html/. )
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
@@ -64,6 +61,10 @@ src_prepare() {
# fix info file for category directory
if [[ ${PV} = *9999 ]]; then
+ sed -i -e
+ 's/Texinfo documentation system/Libraries/' \
+ doc/fftw3."info" || die "failed to fix info file"
+
eautoreconf
fi
}
@@ -81,7 +82,6 @@ multilib_src_configure() {
local myconf=(
--enable-shared
- $([[ ${PV} = *9999 ]] && echo "--enable-maintainer-mode")
$(use_enable static-libs static)
$(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
$(use_enable fortran)
@@ -94,7 +94,7 @@ multilib_src_configure() {
# altivec, sse, single-paired only work for single
myconf+=(
--enable-single
- $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable altivec)
$(use_enable cpu_flags_x86_avx avx)
$(use_enable cpu_flags_x86_avx2 avx2)
$(use_enable cpu_flags_x86_sse sse)
@@ -132,14 +132,7 @@ multilib_src_configure() {
;;
esac
- local MY_S="${S}"
- #out-of-source build is broken for 9999 due to maintainer mode
- if [[ ${PV} = *9999 ]]; then
- cp -al "${S}"/* "${BUILD_DIR}"/
- MY_S="${BUILD_DIR}"
- fi
-
- ECONF_SOURCE="${MY_S}" econf "${myconf[@]}" MPICC="$(tc-getCC) -lmpi"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC)"
}
src_configure() {
@@ -147,7 +140,7 @@ src_configure() {
}
src_compile() {
- multibuild_foreach_variant multilib-minimal_src_compile all $([[ ${PV} = *9999 ]] && usev doc)
+ multibuild_foreach_variant multilib-minimal_src_compile
}
multilib_src_test() {
@@ -165,7 +158,6 @@ src_test() {
}
src_install() {
- use doc && HTML_DOCS=( doc/html/. )
multibuild_foreach_variant multilib-minimal_src_install
dodoc CONVENTIONS
@@ -173,6 +165,8 @@ src_install() {
dodoc doc/*.pdf
docinto faq
dodoc -r doc/FAQ/fftw-faq.html/.
+ else
+ rm -r "${ED%/}"/usr/share/doc/${PF}/html || die
fi
local x