summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/getdata')
-rw-r--r--sci-libs/getdata/Manifest1
-rw-r--r--sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch16
-rw-r--r--sci-libs/getdata/files/getdata-0.8.5-serial-test.patch42
-rw-r--r--sci-libs/getdata/getdata-0.8.5.ebuild95
-rw-r--r--sci-libs/getdata/metadata.xml14
5 files changed, 168 insertions, 0 deletions
diff --git a/sci-libs/getdata/Manifest b/sci-libs/getdata/Manifest
new file mode 100644
index 000000000000..df04fe92d4c2
--- /dev/null
+++ b/sci-libs/getdata/Manifest
@@ -0,0 +1 @@
+DIST getdata-0.8.5.tar.bz2 1015954 SHA256 ee0322c1cca62660daed7941b24d41fc902cd7989539dcba432f5514f682a64e SHA512 3a87ea2fbaa5491ac1d6faecdf10f0a80eef62fb8beefc6103f7f18e74efd404884f100f1d123b1fec672d1a09ea2c87e75626b7c62ea56b568a11cc44feaad0 WHIRLPOOL 7c4566bf7a56d99d41da7d007469d85ea5194f7b7417e6c5e976397f5514f9efd2ad47476f03e050f8dc30cd5348fc02eb7aa5048b14bf62fce629d602d7d84a
diff --git a/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch b/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch
new file mode 100644
index 000000000000..45a6c7e14c31
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch
@@ -0,0 +1,16 @@
+ bindings/python/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
+index c2ab221..f5ade68 100644
+--- a/bindings/python/Makefile.am
++++ b/bindings/python/Makefile.am
+@@ -35,7 +35,7 @@ LIBS=
+
+ BUILT_SOURCES = pyconstants.c
+ AM_CFLAGS = ${WALL} -fno-strict-aliasing
+-AM_CPPFLAGS = $(CPPFLAGS) $(PYTHON_CPPFLAGS) $(NUMPY_CPPFLAGS)
++AM_CPPFLAGS = $(CPPFLAGS) $(PYTHON_CPPFLAGS) $(NUMPY_CPPFLAGS) -I$(top_srcdir)/src
+ pygetdata_la_LDFLAGS = -module -avoid-version \
+ -export-symbols-regex initpygetdata
+ pygetdata_la_LIBADD = $(PYTHON_LIBS) ../../src/libgetdata.la
diff --git a/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch b/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch
new file mode 100644
index 000000000000..976757ea8646
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch
@@ -0,0 +1,42 @@
+ bindings/Makefile.am | 6 +-----
+ bindings/python/test/Makefile.am | 3 +--
+ 2 files changed, 2 insertions(+), 7 deletions(-)
+
+diff --git a/bindings/Makefile.am b/bindings/Makefile.am
+index df53b0f..ec33316 100644
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
+@@ -38,10 +38,6 @@ if MAKE_MATLABBINDINGS
+ MATLAB_SUBDIR=matlab
+ endif
+
+-if MAKE_PYBINDINGS
+-PY_SUBDIR=python
+-endif
+-
+ if MAKE_PERLBINDINGS
+ PERL_SUBDIR=perl
+ endif
+@@ -52,7 +48,7 @@ make_parameters_SOURCES = make_parameters.c
+ nodist_make_parameters_SOURCES = ../src/getdata.h ../src/gd_config.h
+
+ SUBDIRS = . ${F77_SUBDIR} ${CXX_SUBDIR} ${IDL_SUBDIR} ${MATLAB_SUBDIR} \
+- ${PY_SUBDIR} ${PERL_SUBDIR}
++ ${PERL_SUBDIR}
+
+ make_parameters$(EXEEXT): $(make_parameters_SOURCES) \
+ $(nodist_make_parameters_SOURCES)
+diff --git a/bindings/python/test/Makefile.am b/bindings/python/test/Makefile.am
+index d159cad..b793b02 100644
+--- a/bindings/python/test/Makefile.am
++++ b/bindings/python/test/Makefile.am
+@@ -18,8 +18,7 @@
+ # along with GetData; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ #
+-AUTOMAKE_OPTIONS = foreign
+-
++AUTOMAKE_OPTIONS = foreign serial-tests
+ if TEST_PYTHON
+ TESTS_ENVIRONMENT=${DL_LIBRARY_PATH}=${${DL_LIBRARY_PATH}}:../../../src/.libs PYTHONPATH=../.libs/ ${PYTHON}
+ pyTESTS=callback.py big_test.py
diff --git a/sci-libs/getdata/getdata-0.8.5.ebuild b/sci-libs/getdata/getdata-0.8.5.ebuild
new file mode 100644
index 000000000000..4282094c81c2
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.8.5.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+AUTOTOOLS_AUTORECONF=true
+
+FORTRAN_STANDARD="95"
+FORTRAN_NEEDED=fortran
+
+inherit autotools-utils fortran-2 python-r1
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="http://getdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 debug fortran lzma python perl static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-serial-test.patch
+ "${FILESDIR}"/${P}-out-of-source.patch
+ )
+
+src_configure() {
+ local myeconfargs=()
+ use perl && myeconfargs+=( --with-perl-dir=vendor )
+ myeconfargs+=(
+ --disable-idl
+ --without-libslim
+ --with-libz
+ --docdir="${EPREFIX}/usr/share/doc/${P}"
+ $(use_enable debug)
+ $(use_enable fortran)
+ $(use_enable fortran fortran95)
+ $(use_enable python)
+ $(use_enable perl)
+ $(use_with bzip2 libbz2)
+ $(use_with lzma liblzma)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ python_copy_sources
+ building() {
+ cd "${BUILD_DIR}"/bindings/python || die
+ sed "s:-lpython...:$(python_get_LIBS):g" -i Makefile || die
+ emake \
+ PYTHON_VERSION="${EPYTHON#python}" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)"
+ }
+ python_foreach_impl building
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use python; then
+ installation() {
+ cd "${BUILD_DIR}"/bindings/python || die
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="${EPYTHON#python}" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ install
+ find \
+ "${ED}/$(python_get_sitedir)" \
+ -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+ }
+ python_foreach_impl installation
+ fi
+}
diff --git a/sci-libs/getdata/metadata.xml b/sci-libs/getdata/metadata.xml
new file mode 100644
index 000000000000..ac6fc3235bb0
--- /dev/null
+++ b/sci-libs/getdata/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The GetData Project is the reference implementation of the Dirfile
+ Standards, a filesystem-based, column-oriented database format for
+ time-ordered binary data. The Dirfile database format is designed to
+ provide a fast, simple format for storing and reading data.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">getdata</remote-id>
+ </upstream>
+</pkgmetadata>