summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gloo')
-rw-r--r--sci-libs/gloo/Manifest1
-rw-r--r--sci-libs/gloo/gloo-2023.01.17-r2.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/sci-libs/gloo/Manifest b/sci-libs/gloo/Manifest
index 4a4ee57c7206..c03bec1fad19 100644
--- a/sci-libs/gloo/Manifest
+++ b/sci-libs/gloo/Manifest
@@ -1,2 +1 @@
-DIST gloo-2023.01.17.tar.gz 252199 BLAKE2B 66b5fc6786a4c07aa639a30036a21d86f43c1577a950934f558051f241d198dd3e0d7bd9da39835c5e3d617a754164cb77ae30b9bc284b0119436bf0a26f5000 SHA512 d39102ed00c813576066b755730e367337f2558a4223fe8dd127bd48882db6a97c67522782f7e7b00c36198ccd2096e61e84382358783d2edb1ca4ee55123344
DIST gloo-2023.05.19.tar.gz 252199 BLAKE2B 66b5fc6786a4c07aa639a30036a21d86f43c1577a950934f558051f241d198dd3e0d7bd9da39835c5e3d617a754164cb77ae30b9bc284b0119436bf0a26f5000 SHA512 d39102ed00c813576066b755730e367337f2558a4223fe8dd127bd48882db6a97c67522782f7e7b00c36198ccd2096e61e84382358783d2edb1ca4ee55123344
diff --git a/sci-libs/gloo/gloo-2023.01.17-r2.ebuild b/sci-libs/gloo/gloo-2023.01.17-r2.ebuild
deleted file mode 100644
index 8518665b3cd4..000000000000
--- a/sci-libs/gloo/gloo-2023.01.17-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit cmake cuda
-
-CommitId=10909297fedab0a680799211a299203e53515032
-
-DESCRIPTION="library of floating-point neural network inference operators"
-HOMEPAGE="https://github.com/facebookincubator/gloo/"
-SRC_URI="https://github.com/facebookincubator/${PN}/archive/${CommitId}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cuda libuv mpi redis ssl test"
-
-RDEPEND="
- cuda? ( <dev-util/nvidia-cuda-toolkit-12:= )
- libuv? ( dev-libs/libuv )
- mpi? ( virtual/mpi )
- redis? (
- dev-db/redis
- dev-libs/hiredis
- )
- ssl? ( dev-libs/openssl:0/1.1 )
-"
-DEPEND="${RDEPEND}
-"
-
-BDEPEND="test? ( dev-cpp/gtest )"
-RESTRICT="test" # For some test the network is needed
-
-S="${WORKDIR}"/${PN}-${CommitId}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2022.05.18-gentoo.patch
- "${FILESDIR}"/${P}-cuda.patch
- "${FILESDIR}"/${P}-ssl3.patch
-)
-
-src_prepare() {
- eapply_user
- cmake_src_prepare
- use cuda && cuda_add_sandbox
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TEST=$(usex test ON OFF)
- -DUSE_CUDA=$(usex cuda ON OFF)
- -DGLOO_USE_CUDA_TOOLKIT=$(usex cuda ON OFF)
- -DUSE_LIBUV=$(usex libuv ON OFF)
- -DUSE_MPI=$(usex mpi ON OFF)
- -DUSE_REDIS=$(usex redis ON OFF)
- -DUSE_TCP_OPENSSL_LINK=$(usex ssl ON OFF)
- )
- if use cuda; then
- mycmakeargs+=(
- -DCMAKE_CUDA_FLAGS="$(cuda_gccdir -f | tr -d \")"
- )
- fi
- cmake_src_configure
-}