summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hipFFT/files/hipFFT-5.0.2-gentoo-install-locations.patch')
-rw-r--r--sci-libs/hipFFT/files/hipFFT-5.0.2-gentoo-install-locations.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/hipFFT/files/hipFFT-5.0.2-gentoo-install-locations.patch b/sci-libs/hipFFT/files/hipFFT-5.0.2-gentoo-install-locations.patch
new file mode 100644
index 000000000000..eefdb2aaaaf5
--- /dev/null
+++ b/sci-libs/hipFFT/files/hipFFT-5.0.2-gentoo-install-locations.patch
@@ -0,0 +1,28 @@
+Index: hipFFT-rocm-5.0.2/library/CMakeLists.txt
+===================================================================
+--- hipFFT-rocm-5.0.2.orig/library/CMakeLists.txt
++++ hipFFT-rocm-5.0.2/library/CMakeLists.txt
+@@ -81,7 +81,7 @@ target_include_directories( hipfft
+ PUBLIC $<BUILD_INTERFACE:${CMAKE_SOURCE_DIR}/library/include>
+ $<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/include>
+ $<BUILD_INTERFACE:${HIP_INCLUDE_DIRS}>
+- $<INSTALL_INTERFACE:include>
++ $<INSTALL_INTERFACE:include/hipfft>
+ ${HIP_INCLUDE_DIRS}
+ )
+
+@@ -142,13 +142,11 @@ if( ROCM_FOUND )
+ rocm_install_targets( TARGETS hipfft
+ INCLUDE
+ ${CMAKE_SOURCE_DIR}/library/include
+- ${CMAKE_BINARY_DIR}/include
+- PREFIX hipfft )
++ ${CMAKE_BINARY_DIR}/include )
+ rocm_export_targets( TARGETS hip::hipfft
+ PREFIX hipfft
+ DEPENDS PACKAGE hip
+ NAMESPACE hip:: )
+- rocm_install_symlink_subdir( hipfft )
+
+ # Package specific CPACK vars
+ if( NOT BUILD_WITH_LIB STREQUAL "CUDA" )