summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hipRAND/hipRAND-5.6.0.ebuild')
-rw-r--r--sci-libs/hipRAND/hipRAND-5.6.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/sci-libs/hipRAND/hipRAND-5.6.0.ebuild b/sci-libs/hipRAND/hipRAND-5.6.0.ebuild
deleted file mode 100644
index d0bd5ace71e4..000000000000
--- a/sci-libs/hipRAND/hipRAND-5.6.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ROCM_VERSION=${PV}
-
-inherit cmake rocm
-
-DESCRIPTION="CU / ROCM agnostic hip RAND implementation"
-HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipRAND"
-SRC_URI="https://github.com/ROCmSoftwarePlatform/hipRAND/archive/refs/tags/rocm-${PV}.tar.gz -> hipFFT-rocm-${PV}.tar.gz"
-REQUIRED_USE="${ROCM_REQUIRED_USE}"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0/$(ver_cut 1-2)"
-
-RESTRICT="test"
-
-RDEPEND="dev-util/hip
- sci-libs/rocRAND:${SLOT}[${ROCM_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND=""
-
-S="${WORKDIR}/hipRAND-rocm-${PV}"
-
-src_configure() {
- local mycmakeargs=(
- -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
- -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
- -DROCM_SYMLINK_LIBS=OFF
- )
-
- CXX=hipcc cmake_src_configure
-}