summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/huggingface_hub/huggingface_hub-0.13.4-r1.ebuild')
-rw-r--r--sci-libs/huggingface_hub/huggingface_hub-0.13.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/huggingface_hub/huggingface_hub-0.13.4-r1.ebuild b/sci-libs/huggingface_hub/huggingface_hub-0.13.4-r1.ebuild
new file mode 100644
index 000000000000..7c519b339f79
--- /dev/null
+++ b/sci-libs/huggingface_hub/huggingface_hub-0.13.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #Several modules not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest