summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/huggingface_hub/huggingface_hub-0.13.4.ebuild')
-rw-r--r--sci-libs/huggingface_hub/huggingface_hub-0.13.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/huggingface_hub/huggingface_hub-0.13.4.ebuild b/sci-libs/huggingface_hub/huggingface_hub-0.13.4.ebuild
new file mode 100644
index 000000000000..29254fa42182
--- /dev/null
+++ b/sci-libs/huggingface_hub/huggingface_hub-0.13.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #Several modules not yet packaged
+
+distutils_enable_tests pytest