summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/itpp/files')
-rw-r--r--sci-libs/itpp/files/itpp-4.0.6-gcc44.patch60
-rw-r--r--sci-libs/itpp/files/itpp-4.0.7-fastica-fix-endless-loop.patch93
-rw-r--r--sci-libs/itpp/files/itpp-4.2-automake-1.12.patch16
-rw-r--r--sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch26
-rw-r--r--sci-libs/itpp/files/itpp-4.2-pkg-config.patch27
-rw-r--r--sci-libs/itpp/files/itpp-4.2-test-fftw.patch14
6 files changed, 0 insertions, 236 deletions
diff --git a/sci-libs/itpp/files/itpp-4.0.6-gcc44.patch b/sci-libs/itpp/files/itpp-4.0.6-gcc44.patch
deleted file mode 100644
index 6514363a4b48..000000000000
--- a/sci-libs/itpp/files/itpp-4.0.6-gcc44.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -ur itpp-4.0.6.orig/itpp/base/timing.cpp itpp-4.0.6/itpp/base/timing.cpp
---- itpp-4.0.6.orig/itpp/base/timing.cpp 2008-10-08 14:52:24.000000000 +0300
-+++ itpp-4.0.6/itpp/base/timing.cpp 2009-07-30 10:32:45.000000000 +0300
-@@ -27,6 +27,8 @@
- * -------------------------------------------------------------------------
- */
-
-+#include <cstdio>
-+
- #ifndef _MSC_VER
- # include <itpp/config.h>
- #else
-diff -ur itpp-4.0.6.orig/itpp/base/vec.cpp itpp-4.0.6/itpp/base/vec.cpp
---- itpp-4.0.6.orig/itpp/base/vec.cpp 2008-10-08 14:52:24.000000000 +0300
-+++ itpp-4.0.6/itpp/base/vec.cpp 2009-07-30 10:35:45.000000000 +0300
-@@ -27,6 +27,8 @@
- * -------------------------------------------------------------------------
- */
-
-+#include <cstdio>
-+
- #include <itpp/base/vec.h>
- #include <itpp/base/converters.h>
- #include <limits>
-diff -ur itpp-4.0.6.orig/itpp/fixed/cfix.cpp itpp-4.0.6/itpp/fixed/cfix.cpp
---- itpp-4.0.6.orig/itpp/fixed/cfix.cpp 2008-10-08 14:52:24.000000000 +0300
-+++ itpp-4.0.6/itpp/fixed/cfix.cpp 2009-07-30 10:37:21.000000000 +0300
-@@ -27,6 +27,8 @@
- * -------------------------------------------------------------------------
- */
-
-+#include <cstdio>
-+
- #include <itpp/fixed/cfix.h>
- #include <itpp/base/itassert.h>
- #include <iostream>
-diff -ur itpp-4.0.6.orig/itpp/fixed/fix.cpp itpp-4.0.6/itpp/fixed/fix.cpp
---- itpp-4.0.6.orig/itpp/fixed/fix.cpp 2008-10-08 14:52:24.000000000 +0300
-+++ itpp-4.0.6/itpp/fixed/fix.cpp 2009-07-30 10:37:39.000000000 +0300
-@@ -27,6 +27,8 @@
- * -------------------------------------------------------------------------
- */
-
-+#include <cstdio>
-+
- #include <itpp/fixed/fix.h>
- #include <itpp/base/itassert.h>
- #include <iostream>
-diff -ur itpp-4.0.6.orig/itpp/fixed/fixed.cpp itpp-4.0.6/itpp/fixed/fixed.cpp
---- itpp-4.0.6.orig/itpp/fixed/fixed.cpp 2008-10-08 14:52:24.000000000 +0300
-+++ itpp-4.0.6/itpp/fixed/fixed.cpp 2009-07-30 10:37:03.000000000 +0300
-@@ -27,6 +27,8 @@
- * -------------------------------------------------------------------------
- */
-
-+#include <cstdio>
-+
- #include <itpp/fixed/fixed.h>
-
-
diff --git a/sci-libs/itpp/files/itpp-4.0.7-fastica-fix-endless-loop.patch b/sci-libs/itpp/files/itpp-4.0.7-fastica-fix-endless-loop.patch
deleted file mode 100644
index 8d232a421d64..000000000000
--- a/sci-libs/itpp/files/itpp-4.0.7-fastica-fix-endless-loop.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-diff -ru libitpp-4.0.7/itpp/signal/fastica.cpp libitpp-4.0.7.patched/itpp/signal/fastica.cpp
---- libitpp-4.0.7/itpp/signal/fastica.cpp 2009-12-27 01:38:47.000000000 +0100
-+++ libitpp-4.0.7.patched/itpp/signal/fastica.cpp 2010-07-08 16:32:04.000000000 +0200
-@@ -90,7 +90,7 @@
- static mat mpower(const mat A, const double y);
- static ivec getSamples(const int max, const double percentage);
- static vec sumcol(const mat A);
--static void fpica(const mat X, const mat whiteningMatrix, const mat dewhiteningMatrix, const int approach, const int numOfIC, const int g, const int finetune, const double a1, const double a2, double myy, const int stabilization, const double epsilon, const int maxNumIterations, const int maxFinetune, const int initState, mat guess, double sampleSize, mat & A, mat & W);
-+static bool fpica(const mat X, const mat whiteningMatrix, const mat dewhiteningMatrix, const int approach, const int numOfIC, const int g, const int finetune, const double a1, const double a2, double myy, const int stabilization, const double epsilon, const int maxNumIterations, const int maxFinetune, const int initState, mat guess, double sampleSize, mat & A, mat & W);
- /*! @} */
-
- namespace itpp
-@@ -124,7 +124,7 @@
- }
-
- // Call main function
--void Fast_ICA::separate(void)
-+bool Fast_ICA::separate(void)
- {
-
- int Dim = numOfIC;
-@@ -159,13 +159,14 @@
-
- }
-
-+ bool result = true;
- if (PCAonly == false) {
-
- Dim = whitesig.rows();
-
- if (numOfIC > Dim) numOfIC = Dim;
-
-- fpica(whitesig, whiteningMatrix, dewhiteningMatrix, approach, numOfIC, g, finetune, a1, a2, mu, stabilization, epsilon, maxNumIterations, maxFineTune, initState, guess, sampleSize, A, W);
-+ result = fpica(whitesig, whiteningMatrix, dewhiteningMatrix, approach, numOfIC, g, finetune, a1, a2, mu, stabilization, epsilon, maxNumIterations, maxFineTune, initState, guess, sampleSize, A, W);
-
- icasig = W * mixedSig;
-
-@@ -174,6 +175,7 @@
- else { // PCA only : returns E as IcaSig
- icasig = VecPr;
- }
-+ return result;
- }
-
- void Fast_ICA::set_approach(int in_approach) { approach = in_approach; if (approach == FICA_APPROACH_DEFL) finetune = true; }
-@@ -437,7 +439,7 @@
-
- }
-
--static void fpica(const mat X, const mat whiteningMatrix, const mat dewhiteningMatrix, const int approach, const int numOfIC, const int g, const int finetune, const double a1, const double a2, double myy, const int stabilization, const double epsilon, const int maxNumIterations, const int maxFinetune, const int initState, mat guess, double sampleSize, mat & A, mat & W)
-+static bool fpica(const mat X, const mat whiteningMatrix, const mat dewhiteningMatrix, const int approach, const int numOfIC, const int g, const int finetune, const double a1, const double a2, double myy, const int stabilization, const double epsilon, const int maxNumIterations, const int maxFinetune, const int initState, mat guess, double sampleSize, mat & A, mat & W)
- {
-
- int vectorSize = X.rows();
-@@ -511,7 +513,7 @@
- A = dewhiteningMatrix * B;
- W = transpose(B) * whiteningMatrix;
-
-- return;
-+ return false;
- }
-
- B = B * mpower(transpose(B) * B , -0.5);
-@@ -769,7 +771,7 @@
-
- } // IF round
-
-- break;
-+ return false;
-
- } // IF numFailures > failureLimit
-
-@@ -990,5 +992,5 @@
- } // While round <= numOfIC
-
- } // ELSE Deflation
--
-+ return true;
- } // FPICA
-diff -ru libitpp-4.0.7/itpp/signal/fastica.h libitpp-4.0.7.patched/itpp/signal/fastica.h
---- libitpp-4.0.7/itpp/signal/fastica.h 2009-12-27 01:38:47.000000000 +0100
-+++ libitpp-4.0.7.patched/itpp/signal/fastica.h 2010-07-08 16:24:37.000000000 +0200
-@@ -134,8 +134,9 @@
- \brief Explicit launch of main FastICA function
-
- Explicit launch of the Fast_ICA algorithm.
-+ \returns true if algorithm converged and false otherwise
- */
-- void separate(void);
-+ bool separate(void);
-
- /*!
- \brief Set approach : FICA_APPROACH_DEFL or FICA_APPROACH_SYMM (default)
diff --git a/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch b/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch
deleted file mode 100644
index f383d6fda591..000000000000
--- a/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- configure.ac | 2 ++
- 1 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 4f06171..a1e8448 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -27,6 +27,8 @@ AC_CONFIG_MACRO_DIR([m4])
- AC_CONFIG_AUX_DIR([build-aux])
- AM_INIT_AUTOMAKE([-Wall -Werror])
-
-+AM_PROG_AR
-+
- # Shared library versioning
- GENERIC_LIBRARY_VERSION="7:0:0"
- # | | |
diff --git a/sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch b/sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch
deleted file mode 100644
index a852abc5cc4c..000000000000
--- a/sci-libs/itpp/files/itpp-4.2-fastica-correct-dim.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -ru itpp-4.2/itpp/signal/fastica.cpp itpp-4.2.new//itpp/signal/fastica.cpp
---- itpp-4.2/itpp/signal/fastica.cpp 2011-06-07 17:47:32.261000884 +0200
-+++ itpp-4.2.new//itpp/signal/fastica.cpp 2011-06-07 17:31:25.757000915 +0200
-@@ -147,6 +147,9 @@
-
- whitenv(mixedSigC, E, diag(D), whitesig, whiteningMatrix, dewhiteningMatrix);
-
-+ Dim = whitesig.rows();
-+
-+ if (numOfIC > Dim) numOfIC = Dim;
-
- ivec NcFirst = to_ivec(zeros(numOfIC));
- vec NcVp = D;
-@@ -161,10 +164,6 @@
- bool result = true;
- if (PCAonly == false) {
-
-- Dim = whitesig.rows();
--
-- if (numOfIC > Dim) numOfIC = Dim;
--
- result = fpica(whitesig, whiteningMatrix, dewhiteningMatrix, approach, numOfIC, g, finetune, a1, a2, mu, stabilization, epsilon, maxNumIterations, maxFineTune, initState, guess, sampleSize, A, W);
-
- icasig = W * mixedSig;
-Nur in itpp-4.2/itpp/signal: fastica.cpp.orig.
-Nur in itpp-4.2/itpp/signal: fastica.h.orig.
diff --git a/sci-libs/itpp/files/itpp-4.2-pkg-config.patch b/sci-libs/itpp/files/itpp-4.2-pkg-config.patch
deleted file mode 100644
index 5a18952707bb..000000000000
--- a/sci-libs/itpp/files/itpp-4.2-pkg-config.patch
+++ /dev/null
@@ -1,27 +0,0 @@
- configure.ac | 2 +-
- itpp.pc.in | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 4f06171..d3d7b76 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -322,7 +322,7 @@ test "x$FFT_LIBS" != x && LIBS="$FFT_LIBS $LIBS"
- CPPFLAGS="`echo \"$CPPFLAGS\" | sed -e 's/ */ /g' -e 's/^ //' -e 's/ $//'`"
- LDFLAGS="`echo \"$LDFLAGS\" | sed -e 's/ */ /g' -e 's/^ //' -e 's/ $//'`"
- LIBS="`echo \"$LIBS\" | sed -e 's/ */ /g' -e 's/^ //' -e 's/ $//'`"
--LDLIBS="`echo \"$LDFLAGS $LIBS\" | sed -e 's/^ //' -e 's/ $//'`"
-+LDLIBS="`echo \"$LIBS\" | sed -e 's/^ //' -e 's/ $//'`"
-
- if test $enable_explicit_deps = yes; then
- EXPLICIT_LIBS=" $LDLIBS" # the leading space is important here...
-diff --git a/itpp.pc.in b/itpp.pc.in
-index 4018865..48a9543 100644
---- a/itpp.pc.in
-+++ b/itpp.pc.in
-@@ -9,4 +9,4 @@ Version: @PACKAGE_VERSION@
- URL: http://itpp.sourceforge.net/
- Libs: -L${libdir} -l@PACKAGE@@EXPLICIT_LIBS@
- Libs.private:@PRIVATE_LIBS@
--Cflags: -I${includedir} @CXXFLAGS_OPT@
-+Cflags: -I${includedir}
diff --git a/sci-libs/itpp/files/itpp-4.2-test-fftw.patch b/sci-libs/itpp/files/itpp-4.2-test-fftw.patch
deleted file mode 100644
index b7bb11dcc4ff..000000000000
--- a/sci-libs/itpp/files/itpp-4.2-test-fftw.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- itpp/branches/itpp-4-2/tests/Makefile.am 2010/09/21 18:23:47 1807
-+++ itpp/branches/itpp-4-2/tests/Makefile.am 2010/12/30 23:47:09 1837
-@@ -20,9 +20,9 @@
-
- OPTIM_TESTS = newton_search_test
-
--SIGNAL_TESTS = filter_test source_test window_test
-+SIGNAL_TESTS = filter_test source_test
- SIGNAL_LAP_TESTS = fastica_test poly_test
--SIGNAL_FFT_TESTS = freq_filt_test sigfun_test transforms_test
-+SIGNAL_FFT_TESTS = freq_filt_test sigfun_test transforms_test window_test
- SIGNAL_LAP_FFT_TESTS = filter_design_test
-
- STAT_TESTS = histogram_test