summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild')
-rw-r--r--sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild b/sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild
new file mode 100644
index 000000000000..23fb0ef4f630
--- /dev/null
+++ b/sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="reading, writing, and editing of XLS (BIFF8 format) files using C++"
+HOMEPAGE="https://www.codeproject.com/Articles/42504/ExcelFormat-Library"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}/libExcelFormat"
+
+LICENSE="CPOL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=( "${FILESDIR}"/${P}-Wliteral-suffix.patch )
+
+src_configure() {
+ tc-export CXX
+}
+
+src_install() {
+ doheader *.h*
+ dolib.so libExcelFormat.so*
+}