summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libghemical/libghemical-3.0.0.ebuild')
-rw-r--r--sci-libs/libghemical/libghemical-3.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/libghemical/libghemical-3.0.0.ebuild b/sci-libs/libghemical/libghemical-3.0.0.ebuild
new file mode 100644
index 000000000000..d1d3dbf4418f
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-3.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mopac7 mpqc static-libs"
+
+RDEPEND="
+ mopac7? ( >=sci-chemistry/mopac7-1.13-r1 )
+ mpqc? (
+ >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.98-gl.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}