summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libnova')
-rw-r--r--sci-libs/libnova/Manifest2
-rw-r--r--sci-libs/libnova/files/libnova-0.12.1-configure.patch17
-rw-r--r--sci-libs/libnova/libnova-0.12.3.ebuild51
-rw-r--r--sci-libs/libnova/libnova-0.14.0.ebuild39
4 files changed, 0 insertions, 109 deletions
diff --git a/sci-libs/libnova/Manifest b/sci-libs/libnova/Manifest
index 7ad8bce787b2..932ef1e10880 100644
--- a/sci-libs/libnova/Manifest
+++ b/sci-libs/libnova/Manifest
@@ -1,3 +1 @@
-DIST libnova-0.12.3.tar.gz 1505676 BLAKE2B 96ece7030bcbfa831c6daa3ef02a1a9d100bd5145d881a9596e0a42ba1917dde007e79da95a433870957c526d0be65f8cb480b5633b0e9a5115a731688e79aea SHA512 e39c55c339dc2d7c899ffb7d0a898a5c2d6ebca5cf3a788db21d84f230a7379bfc0dd4736ed7ae66d8a449d1be9d68b8a4382ae55af4aa638bb734402c43bc72
-DIST libnova-0.14.0.tar.gz 1547373 BLAKE2B 75078d77868419e3cc6d6a7b5c513ebbf32062e4c08c54d5fa80d6e0f4d44eff8118b5d3df4b32d5e14e2f1b9eb989b154391a98eb79dcc83b2cf5f22bad67e6 SHA512 373d32e4f380563f895483d9054cf19bbfc69e32089f75dc91f84daf28610eba94f5615b0eb7004b25b9c702450d594463606b349b93dc9cde46d0d860029da7
DIST libnova-0.15.0.tar.gz 1533794 BLAKE2B e87ffd3b8a895ca7ac9913ad3aacff526718442546df5687f2156718f721665ffff27e69af4bcb65bac5df1fda89fc6fc8fe9876a4b74392986771cf157dc48c SHA512 77ab0ccbfe462c03a21e88656cb4d6389994ea1da0ee8da997f19a83d24ad8fd9e505e70e1580b75332e826e5b7859b5f2af4417f65eb811440493ba586f2574
diff --git a/sci-libs/libnova/files/libnova-0.12.1-configure.patch b/sci-libs/libnova/files/libnova-0.12.1-configure.patch
deleted file mode 100644
index b87b27d75dc9..000000000000
--- a/sci-libs/libnova/files/libnova-0.12.1-configure.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- configure.in.orig 2007-11-25 19:24:54.503391146 +0000
-+++ configure.in 2007-11-25 19:26:16.736077320 +0000
-@@ -54,7 +54,6 @@
- AC_STRUCT_TM
-
- LIBS="$LIBS -lm"
--CFLAGS=-Wall
-
- # Checks for header files.
- AC_HEADER_STDC
-@@ -74,5 +73,6 @@
- src/libnova/Makefile
- lntest/Makefile
- doc/Makefile
-+doc/doxyfile
- examples/Makefile
- ])
diff --git a/sci-libs/libnova/libnova-0.12.3.ebuild b/sci-libs/libnova/libnova-0.12.3.ebuild
deleted file mode 100644
index f531c830dbd5..000000000000
--- a/sci-libs/libnova/libnova-0.12.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-inherit eutils autotools flag-o-matic
-
-DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
-HOMEPAGE="http://libnova.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc ppc64 x86"
-IUSE="doc examples"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.12.1-configure.patch
- # 0.12.3 does not pass test with > -02
- replace-flags -O? -O1
- eautoreconf
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc; then
- cd doc
- emake doc || die "emake in doc failed"
- fi
-}
-
-src_test() {
- emake check || die "emake check failed"
- "${S}"/lntest/lntest || die "lntest failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README || die
- if use doc; then
- dohtml doc/html/* || die "dohtml failed"
- fi
- if use examples; then
- make clean
- rm -f examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
diff --git a/sci-libs/libnova/libnova-0.14.0.ebuild b/sci-libs/libnova/libnova-0.14.0.ebuild
deleted file mode 100644
index 23a5867f38e0..000000000000
--- a/sci-libs/libnova/libnova-0.14.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
-HOMEPAGE="http://libnova.sourceforge.net/"
-SRC_URI="https://dev.gentoo.org/~bicatali/${P}.tar.gz"
-# bad tar ball on sf, rebuild it from svn
-#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc examples static-libs"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_compile() {
- emake
- use doc && emake doc
-}
-
-src_install() {
- default
- use doc && dohtml doc/html/*
- if use examples; then
- make clean
- rm -f examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}