summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/miopen/files/miopen-4.2.0-disable-no-inline-boost.patch')
-rw-r--r--sci-libs/miopen/files/miopen-4.2.0-disable-no-inline-boost.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/sci-libs/miopen/files/miopen-4.2.0-disable-no-inline-boost.patch b/sci-libs/miopen/files/miopen-4.2.0-disable-no-inline-boost.patch
new file mode 100644
index 000000000000..769217acd9d1
--- /dev/null
+++ b/sci-libs/miopen/files/miopen-4.2.0-disable-no-inline-boost.patch
@@ -0,0 +1,14 @@
+This let MIOpen compatible with >boost-1.72, for example 1.76
+
+Suggested by: Michael Boone <mike@protagonistsystems.io>
+
+--- a/CMakeLists.txt 2021-07-23 01:26:15.377754243 -0700
++++ b/CMakeLists.txt 2021-07-23 01:29:23.925685190 -0700
+@@ -216,6 +216,7 @@
+ message(STATUS "Hip compiler flags: ${HIP_COMPILER_FLAGS}")
+
+ add_definitions("-DHIP_COMPILER_FLAGS=${HIP_COMPILER_FLAGS}")
++add_definitions("-DBOOST_CONTAINER_DISABLE_NOINLINE")
+
+
+ # HIP