summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pyshp/pyshp-1.2.0.ebuild')
-rw-r--r--sci-libs/pyshp/pyshp-1.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/pyshp/pyshp-1.2.0.ebuild b/sci-libs/pyshp/pyshp-1.2.0.ebuild
new file mode 100644
index 000000000000..dfc89c31310e
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.python.org/pypi/pyshp/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"