summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rocSPARSE/rocSPARSE-5.1.3.ebuild')
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-5.1.3.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-5.1.3.ebuild b/sci-libs/rocSPARSE/rocSPARSE-5.1.3.ebuild
index 0ed300de5755..cb8a7d8c23fb 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-5.1.3.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-5.1.3.ebuild
@@ -91,7 +91,7 @@ src_prepare() {
mkdir -p "${BUILD_DIR}"/clients/matrices
# compile and use the mtx2csr converter. Do not use any optimization flags, because it causes error!
edo $(tc-getCXX) deps/convert.cpp -o deps/convert
- find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
+ find "${WORKDIR}" -maxdepth 2 -regextype grep -E -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).csr
ebegin "Converting ${mtxfile} to ${destination}"