summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/scikit-learn')
-rw-r--r--sci-libs/scikit-learn/Manifest1
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.0.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index f406527664be..0b302e797dd9 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1 +1,2 @@
DIST scikit-learn-0.24.2.tar.gz 7589697 BLAKE2B a5a32db690e76d6ecfcb12d57a7f84ebcc7e67ecb73258c1d923f9b98a9d87c46aac96918ef7c3d8741f5dbeb46f169c73a7744fb7b92e6ab5cf42101a6bc2f1 SHA512 2159baf63414b9594918b40e1b72af2ab47349335ad4e3afd9756921f786737ed41d6deb333881e8c5c6e1f7ce9cfa10691b966dc2476c48c051621f9049d2ee
+DIST scikit-learn-1.0.2.tar.gz 6783296 BLAKE2B c5894b83c616117ac69e99d3eafe6b7218e085bfae099b41d09ecafc5cf116d4ef6849e69de2c1d833be1eb1e2479c1d200147ec1fcf73798c4e341dcaaa4d79 SHA512 1921a722ce887e04db94586a8100f435ca26038c32f1841ed8c7d5f17b5c7a3dbf5e036f5b0fca0f9907c32f80db5b082cb04141d14d22719ad78f3cfef51415
diff --git a/sci-libs/scikit-learn/scikit-learn-1.0.2.ebuild b/sci-libs/scikit-learn/scikit-learn-1.0.2.ebuild
new file mode 100644
index 000000000000..8825ce648cf0
--- /dev/null
+++ b/sci-libs/scikit-learn/scikit-learn-1.0.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+DESCRIPTION="Machine learning library for Python"
+HOMEPAGE="https://scikit-learn.org/stable/"
+SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+# This is being very difficult
+RESTRICT="test"
+
+DEPEND="
+ virtual/blas:=
+ virtual/cblas:=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+# For some reason this wants to use urllib to fetch things from the internet
+# distutils_enable_sphinx doc \
+# dev-python/matplotlib \
+# dev-python/memory_profiler \
+# dev-python/numpydoc \
+# dev-python/pandas \
+# dev-python/pillow \
+# dev-python/seaborn \
+# dev-python/sphinx-gallery \
+# dev-python/sphinx-prompt \
+# sci-libs/scikit-image
+
+python_install_all() {
+ find "${S}" -name \*LICENSE.txt -delete || die
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}