summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/shapelib')
-rw-r--r--sci-libs/shapelib/Manifest1
-rw-r--r--sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch118
-rw-r--r--sci-libs/shapelib/shapelib-1.3.0-r1.ebuild66
3 files changed, 0 insertions, 185 deletions
diff --git a/sci-libs/shapelib/Manifest b/sci-libs/shapelib/Manifest
index bb88446b8fa8..f00f2f8fba78 100644
--- a/sci-libs/shapelib/Manifest
+++ b/sci-libs/shapelib/Manifest
@@ -1,2 +1 @@
-DIST shapelib-1.3.0.tar.gz 156301 SHA256 23d474016158ab5077db2f599527631706ba5c0dc7c4178a6a1d685bb014f68f SHA512 286a9faf7d7a6d88db3cceffb4e0fe335e5d754244b4e83110862ba0f88904aa10dd2814aa0c93d7531781cb318052d3f683160c9644f83f93e7d20108ac3b60 WHIRLPOOL 79b44dac05f8ca5e10809f7af1e9d0d1f1f5a2c7009698aa5dd33260a362c75b7e7f09cf535d58b6510f355ff5dfb193f2a0c7d14ef913caa4a0d5b099ef3a5b
DIST shapelib-1.4.0.tar.gz 548990 SHA256 3eddd5f2690f2cf18d8d9798267537a2102a289020b9818f9a31eb626f91a7a1 SHA512 206b81fe859a837e821e449ab1b2dbd5a3aa7abd1871da4aec69e130b6fad6300697429884ce359c90e4b76bca90e2108f32b9fdbd3b92013fa5a39f3bedeeb1 WHIRLPOOL ac411c0a40923aede1236cc5afe77ffc83f2700b95360204f11c9fe0299512728ae8e66017ffb4baa7f9d54f20d7f7e5c0b8a30dc697c611f601fed158dc1557
diff --git a/sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch b/sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch
deleted file mode 100644
index 04963108ec42..000000000000
--- a/sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch
+++ /dev/null
@@ -1,118 +0,0 @@
- Makefile | 41 ++++++++++++++++++++---------------------
- 1 file changed, 20 insertions(+), 21 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 0c41d8a..4149412 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,8 +1,9 @@
-
--PREFIX = /usr/local
--CFLAGS = -g -Wall -fPIC
-+PREFIX ?= /usr/localxs
-+CFLAGS ?= -g -Wall -fPIC
- #CFLAGS = -g -DUSE_CPL
- #CC = g++
-+AR ?= ar
-
- LIBOBJ = shpopen.o dbfopen.o safileio.o shptree.o
- SHPBIN = shpcreate shpadd shpdump shprewind dbfcreate dbfadd dbfdump \
-@@ -10,7 +11,7 @@ SHPBIN = shpcreate shpadd shpdump shprewind dbfcreate dbfadd dbfdump \
-
- default: all
-
--all: $(SHPBIN) shptest lib
-+all: $(SHPBIN) lib
-
- shpopen.o: shpopen.c shapefil.h
- $(CC) $(CFLAGS) -c shpopen.c
-@@ -25,46 +26,46 @@ safileio.o: safileio.c shapefil.h
- $(CC) $(CFLAGS) -c safileio.c
-
- shpcreate: shpcreate.c shpopen.o safileio.o
-- $(CC) $(CFLAGS) shpcreate.c shpopen.o safileio.o $(LINKOPT) -o shpcreate
-+ $(CC) $(CFLAGS) $(LDFLAGS) shpcreate.c shpopen.o safileio.o -o shpcreate
-
- shpadd: shpadd.c shpopen.o safileio.o
-- $(CC) $(CFLAGS) shpadd.c shpopen.o safileio.o $(LINKOPT) -o shpadd
-+ $(CC) $(CFLAGS) $(LDFLAGS) shpadd.c shpopen.o safileio.o -o shpadd
-
- shpdump: shpdump.c shpopen.o safileio.o
-- $(CC) $(CFLAGS) shpdump.c shpopen.o safileio.o $(LINKOPT) -o shpdump
-+ $(CC) $(CFLAGS) $(LDFLAGS) shpdump.c shpopen.o safileio.o -o shpdump
-
- shprewind: shprewind.c shpopen.o safileio.o
-- $(CC) $(CFLAGS) shprewind.c shpopen.o safileio.o $(LINKOPT) -o shprewind
-+ $(CC) $(CFLAGS) $(LDFLAGS) shprewind.c shpopen.o safileio.o -o shprewind
-
- dbfcreate: dbfcreate.c dbfopen.o safileio.o
-- $(CC) $(CFLAGS) dbfcreate.c dbfopen.o safileio.o $(LINKOPT) -o dbfcreate
-+ $(CC) $(CFLAGS) $(LDFLAGS) dbfcreate.c dbfopen.o safileio.o -o dbfcreate
-
- dbfadd: dbfadd.c dbfopen.o safileio.o
-- $(CC) $(CFLAGS) dbfadd.c dbfopen.o safileio.o $(LINKOPT) -o dbfadd
-+ $(CC) $(CFLAGS) $(LDFLAGS) dbfadd.c dbfopen.o safileio.o -o dbfadd
-
- dbfdump: dbfdump.c dbfopen.o safileio.o
-- $(CC) $(CFLAGS) dbfdump.c dbfopen.o safileio.o $(LINKOPT) -o dbfdump
-+ $(CC) $(CFLAGS) $(LDFLAGS) dbfdump.c dbfopen.o safileio.o -o dbfdump
-
- shptest: shptest.c shpopen.o safileio.o
-- $(CC) $(CFLAGS) shptest.c shpopen.o safileio.o $(LINKOPT) -o shptest
-+ $(CC) $(CFLAGS) $(LDFLAGS) shptest.c shpopen.o safileio.o -o shptest
-
- shputils: shputils.c shpopen.o safileio.o dbfopen.o
-- $(CC) $(CFLAGS) shputils.c shpopen.o safileio.o dbfopen.o $(LINKOPT) -o shputils
-+ $(CC) $(CFLAGS) $(LDFLAGS) shputils.c shpopen.o safileio.o dbfopen.o -o shputils
-
- shptreedump: shptreedump.c shptree.o shpopen.o safileio.o
-- $(CC) $(CFLAGS) shptreedump.c shptree.o shpopen.o safileio.o $(LINKOPT) \
-+ $(CC) $(CFLAGS) $(LDFLAGS) shptreedump.c shptree.o shpopen.o safileio.o \
- -o shptreedump
-
- clean:
- rm -f *.o shptest $(SHPBIN) libshp.a
-
--test: test2 test3
-+test: shptest test2 test3
-
- #
- # Note this stream only works if example data is accessable.
- # Fetch ftp://gdal.velocet.ca/pub/outgoing/shape_eg_data.zip
- #
--test1:
-+test1: shptest
- @./stream1.sh > s1.out
- @if test "`diff s1.out stream1.out`" = '' ; then \
- echo "******* Stream 1 Succeeded *********"; \
-@@ -74,7 +75,7 @@ test1:
- diff s1.out stream1.out; \
- fi
-
--test2:
-+test2: shptest
- @./stream2.sh > s2.out
- @if test "`diff s2.out stream2.out`" = '' ; then \
- echo "******* Stream 2 Succeeded *********"; \
-@@ -85,7 +86,7 @@ test2:
- diff s2.out stream2.out; \
- fi
-
--test3:
-+test3: shptest
- @./makeshape.sh > s3.out
- @if test "`diff s3.out stream3.out`" = '' ; then \
- echo "******* Stream 3 Succeeded *********"; \
-@@ -97,10 +98,8 @@ test3:
- fi
-
-
--lib: libshp.a
--
--libshp.a: $(LIBOBJ)
-- ar r libshp.a $(LIBOBJ)
-+lib: $(LIBOBJ)
-+ $(AR) r libshp.a $(LIBOBJ)
-
- lib_install: libshp.a
- cp libshp.a $(PREFIX)/lib
diff --git a/sci-libs/shapelib/shapelib-1.3.0-r1.ebuild b/sci-libs/shapelib/shapelib-1.3.0-r1.ebuild
deleted file mode 100644
index bfc17c6788cc..000000000000
--- a/sci-libs/shapelib/shapelib-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils toolchain-funcs multilib versionator
-
-DESCRIPTION="Library for manipulating ESRI Shapefiles"
-HOMEPAGE="http://shapelib.maptools.org/"
-SRC_URI="http://download.osgeo.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-DEPEND=""
-RDEPEND=""
-
-static_to_shared() {
- local libstatic=${1}; shift
- local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname $(get_version_component_range 1-2))
- local libdir=$(dirname ${libstatic})
-
- einfo "Making ${soname} from ${libstatic}"
- if [[ ${CHOST} == *-darwin* ]] ; then
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -dynamiclib -install_name "${EPREFIX}"/usr/lib/"${soname}" \
- -Wl,-all_load -Wl,${libstatic} \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- else
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -shared -Wl,-soname=${soname} \
- -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- [[ $(get_version_component_count) -gt 1 ]] && \
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version))
- ln -s ${soname} ${libdir}/${libname}$(get_libname)
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-respect-user.patch
- tc-export CC AR
-}
-
-src_compile() {
- emake CFLAGS="${CFLAGS} -fPIC" lib
- static_to_shared lib*.a
- rm *.o *.a
- emake
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- dobin shp{create,dump,add} dbf{create,dump,add}
- insinto /usr/include/libshp
- doins shapefil.h
- use test && dobin shptest
- dolib.so lib*$(get_libname)*
- dodoc ChangeLog README*
- use static-libs && dolib.a lib*.a
-}