summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/spglib/spglib-1.14.1.ebuild')
-rw-r--r--sci-libs/spglib/spglib-1.14.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/spglib/spglib-1.14.1.ebuild b/sci-libs/spglib/spglib-1.14.1.ebuild
new file mode 100644
index 000000000000..3471996ebea3
--- /dev/null
+++ b/sci-libs/spglib/spglib-1.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Spglib is a C library for finding and handling crystal symmetries"
+HOMEPAGE="https://atztogo.github.io/spglib/"
+SRC_URI="https://github.com/atztogo/spglib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}