summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/sundials/sundials-5.2.0.ebuild')
-rw-r--r--sci-libs/sundials/sundials-5.2.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/sundials/sundials-5.2.0.ebuild b/sci-libs/sundials/sundials-5.2.0.ebuild
index c99c2b643966..5af24cd4ed75 100644
--- a/sci-libs/sundials/sundials-5.2.0.ebuild
+++ b/sci-libs/sundials/sundials-5.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,11 +31,13 @@ DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${P}-fix-license-install-path.patch )
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ use fortran && fortran-2_pkg_setup
}
src_prepare() {