summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/superlu/superlu-4.3-r2.ebuild')
-rw-r--r--sci-libs/superlu/superlu-4.3-r2.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/sci-libs/superlu/superlu-4.3-r2.ebuild b/sci-libs/superlu/superlu-4.3-r2.ebuild
index 5376cd8d1795..e8887bb82b09 100644
--- a/sci-libs/superlu/superlu-4.3-r2.ebuild
+++ b/sci-libs/superlu/superlu-4.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,12 +9,16 @@ MY_PN=SuperLU
DESCRIPTION="Sparse LU factorization library"
HOMEPAGE="https://crd-legacy.lbl.gov/~xiaoye/SuperLU/"
-SRC_URI="https://crd-legacy.lbl.gov/~xiaoye/SuperLU/${PN}_${PV}.tar.gz"
+#SRC_URI="https://portal.nersc.gov/project/sparse/${PN}/${PN}_${PV}.tar.gz"
+# Archive of weird franken-version which we used as 4.3 but upstream changed
+# the above tarball ^. The franken-version we used seemed to have 4.1 references in it?
+# bug #862597.
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}_${PV}.tar.gz"
S="${WORKDIR}/${MY_PN}_${PV}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ppc ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
RESTRICT="!test? ( test )"
@@ -73,12 +77,12 @@ src_install() {
if use doc; then
dodoc DOC/ug.pdf
- dodoc DOC/html/*
+ dodoc -r DOC/html/.
fi
if use examples; then
docinto examples
- dodoc EXAMPLE FORTRAN
+ dodoc -r EXAMPLE FORTRAN
fi
find "${ED}" -name "*.a" -delete || die