summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ufconfig/Manifest3
-rw-r--r--sci-libs/ufconfig/ufconfig-3.5.0.ebuild43
-rw-r--r--sci-libs/ufconfig/ufconfig-3.6.1.ebuild40
-rw-r--r--sci-libs/ufconfig/ufconfig-3.7.0.ebuild43
4 files changed, 0 insertions, 129 deletions
diff --git a/sci-libs/ufconfig/Manifest b/sci-libs/ufconfig/Manifest
index 6a6709e8b6f4..6a421b189c19 100644
--- a/sci-libs/ufconfig/Manifest
+++ b/sci-libs/ufconfig/Manifest
@@ -1,4 +1 @@
-DIST UFconfig-3.5.0.tar.gz 8001 BLAKE2B 39b7c5076f746e872d1bd1427d8601a30359aa21e1d3b90933a5d2ceee7afb27d757a928613ff09a1534afcb160b67a82a2dc567ff8a08dba8efd78a184e9a3f SHA512 d9edd64d6f7c0a48c149990f55f7d0684459205b2a5a029f50412310db580d28f6336164c96784be5bd7441e175c33f6689a752b50d6af5c168d44b7b51f6d37
-DIST UFconfig-3.6.1.tar.gz 8163 BLAKE2B fa22b18b99fa76b0e17e521adb79c3a5d8ebbcdc15418a68365c1f9bcb0fed77aec8a0fd6313614ed83bdf3dd5019fe42ca249917b63a60dda98526772ae855d SHA512 b4b4af9f460f8aea4de7dcd1dcc1ee1aea319bd05de1781ffc2217d0ed1264a6cebcc4139b62fbcc2a6b1f614ff89eb6f277176a59a17b237729ec9822a93920
-DIST UFconfig-3.7.0.tar.gz 8557 BLAKE2B 0ae5b942d1c7f89d6e7df37aacf008a4d8307a5e4fcbce08dffce8968d50b039d68cfbc21412a0957dfe6eba67fa411b48c0e24c1d8775c8c2ddd892054997a6 SHA512 f5aa3723484e05a889434e12fc85521d378430b18d707d7d8807c755ea7046aa28854f8bcb459a42e8764a82f07597b73183a9c7ef070a4b376e76b475cb8d24
DIST UFconfig-3.7.1.tar.gz 8523 BLAKE2B fee3520b4c1305c4684ef4d0fd6cbcc27cd6db957b838642241f75cd6de4468fb5dd61282a0c1484318e56c5b06b8354a78eed2e6df6a5d21e4250883ad1c42a SHA512 a9d562205b6d047d8064d6f61e4f9fdb782774637f0522abef6031e8633c7372db108c69b48098e8b41ffdf786ce7bda0d8df9a3dee634dfb11b5e6073996a22
diff --git a/sci-libs/ufconfig/ufconfig-3.5.0.ebuild b/sci-libs/ufconfig/ufconfig-3.5.0.ebuild
deleted file mode 100644
index b78aeb3a559e..000000000000
--- a/sci-libs/ufconfig/ufconfig-3.5.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit multilib toolchain-funcs
-
-MY_PN=UFconfig
-DESCRIPTION="Common configuration scripts for the SuiteSparse libraries"
-HOMEPAGE="http://www.cise.ufl.edu/research/sparse/UFconfig"
-SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="static-libs"
-DEPEND=""
-
-S="${WORKDIR}/${MY_PN}"
-
-src_compile() {
- echo "$(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo"
- $(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo || die
- echo "$(tc-getCC) ${LDFLAGS} -shared -Wl,-soname,libufconfig.so.${PV} -o libufconfig.so.${PV} UFconfig.lo"
- $(tc-getCC) ${LDFLAGS} -shared -Wl,-soname,libufconfig.so.${PV} -o libufconfig.so.${PV} UFconfig.lo || die
- if use static-libs; then
- echo "$(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o"
- $(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o || die
- echo "$(tc-getAR) libufconfig.a UFconfig.o"
- $(tc-getAR) cr libufconfig.a UFconfig.o
- fi
-}
-
-src_install() {
- dolib.so libufconfig.so.${PV} || die
- dosym libufconfig.so.${PV} /usr/$(get_libdir)/libufconfig.so
- if use static-libs; then
- dolib.a libufconfig.a || die
- fi
- insinto /usr/include
- doins UFconfig.h || die
- dodoc README.txt || die
-}
diff --git a/sci-libs/ufconfig/ufconfig-3.6.1.ebuild b/sci-libs/ufconfig/ufconfig-3.6.1.ebuild
deleted file mode 100644
index 0d9d8fc82870..000000000000
--- a/sci-libs/ufconfig/ufconfig-3.6.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit multilib toolchain-funcs
-
-MY_PN=UFconfig
-DESCRIPTION="Common configuration scripts for the SuiteSparse libraries"
-HOMEPAGE="http://www.cise.ufl.edu/research/sparse/UFconfig"
-SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="static-libs"
-DEPEND=""
-
-S="${WORKDIR}/${MY_PN}"
-
-src_compile() {
- echo "$(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo"
- $(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo || die
- echo "$(tc-getCC) ${LDFLAGS} -shared -Wl,-soname,libufconfig.so.${PV} -o libufconfig.so.${PV} UFconfig.lo"
- $(tc-getCC) ${LDFLAGS} -shared -Wl,-soname,libufconfig.so.${PV} -o libufconfig.so.${PV} UFconfig.lo || die
- if use static-libs; then
- echo "$(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o"
- $(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o || die
- echo "$(tc-getAR) libufconfig.a UFconfig.o"
- $(tc-getAR) cr libufconfig.a UFconfig.o
- fi
-}
-
-src_install() {
- dolib.so libufconfig.so.${PV}
- dosym libufconfig.so.${PV} /usr/$(get_libdir)/libufconfig.so
- use static-libs && dolib.a libufconfig.a
- insinto /usr/include
- doins UFconfig.h
- dodoc README.txt
-}
diff --git a/sci-libs/ufconfig/ufconfig-3.7.0.ebuild b/sci-libs/ufconfig/ufconfig-3.7.0.ebuild
deleted file mode 100644
index 4fe59aac3955..000000000000
--- a/sci-libs/ufconfig/ufconfig-3.7.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit multilib toolchain-funcs
-
-MY_PN=UFconfig
-DESCRIPTION="Common configuration scripts for the SuiteSparse libraries"
-HOMEPAGE="http://www.cise.ufl.edu/research/sparse/UFconfig"
-SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="static-libs"
-DEPEND=""
-
-S="${WORKDIR}/${MY_PN}"
-
-src_compile() {
- echo "$(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo"
- $(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo || die
- local sharedlink="-shared -Wl,-soname,libufconfig$(get_libname ${PV})"
- [[ ${CHOST} == *-darwin* ]] && \
- sharedlink="-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libufconfig$(get_libname ${PV})"
- echo "$(tc-getCC) ${LDFLAGS} ${sharedlink} -o libufconfig$(get_libname ${PV}) UFconfig.lo"
- $(tc-getCC) ${LDFLAGS} ${sharedlink} -o libufconfig$(get_libname ${PV}) UFconfig.lo || die
- if use static-libs; then
- echo "$(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o"
- $(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o || die
- echo "$(tc-getAR) libufconfig.a UFconfig.o"
- $(tc-getAR) cr libufconfig.a UFconfig.o
- fi
-}
-
-src_install() {
- dolib.so libufconfig$(get_libname ${PV})
- dosym libufconfig$(get_libname ${PV}) /usr/$(get_libdir)/libufconfig$(get_libname)
- use static-libs && dolib.a libufconfig.a
- insinto /usr/include
- doins UFconfig.h
- dodoc README.txt
-}