summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/dsfmt/files')
-rw-r--r--sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch b/sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch
new file mode 100644
index 000000000000..fda30002ad7d
--- /dev/null
+++ b/sci-mathematics/dsfmt/files/dsfmt-2.2.4-cc.patch
@@ -0,0 +1,12 @@
+# https://bugs.gentoo.org/780936
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,7 @@ OPTI = -O3 -finline-functions -fomit-frame-pointer -DNDEBUG \
+ #STD = -std=c89 -pedantic
+ #STD = -std=c99 -pedantic
+ STD = -std=c99
+-CC = gcc
++CC ?= gcc
+ CCFLAGS = $(OPTI) $(WARN) $(STD)
+ ALTIFLAGS = -mabi=altivec -maltivec -DHAVE_ALTIVEC
+ OSXALTIFLAGS = -faltivec -maltivec -DHAVE_ALTIVEC