summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/easycrypt')
-rw-r--r--sci-mathematics/easycrypt/Manifest1
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2024.01.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index 3c2d7f0d022c..5265d3450ef7 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1 +1,2 @@
DIST easycrypt-2023.09.tar.gz 1317177 BLAKE2B 98e1c13b530f1cac6f3e166a01627cfb9cd0f1660f51187dac66397caad9cd71fe6b8923ac9757015a50ee479d3427d4906dcdf3bd36012559087657904489b8 SHA512 06fbd3993db951b620c946679566910c8f32035da6d0e8991c794edbc95a31acf3c60c5d3e909a60535ba0252dadf86ccfba2d1998a3929c4653e159d9a4dfac
+DIST easycrypt-2024.01.tar.gz 1349695 BLAKE2B e9c43d43f2c07d75dcb5ee8edf46d1fcfc2a47497fd76c87ef13d52087144acbf3b80ae809c70164eebe046cfb5d585678811163a47cf30c3c55828c3278a4fc SHA512 331612b05f6c47b302f1ceb1d741f47476354bf2d4960c2f55e6bddf3187fea3d40aa687c278fc727bf8994fee95e7af444f109be9a0c9eb9ab455d5fcc7b97d
diff --git a/sci-mathematics/easycrypt/easycrypt-2024.01.ebuild b/sci-mathematics/easycrypt/easycrypt-2024.01.ebuild
new file mode 100644
index 000000000000..9be3ec43e207
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2024.01.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/r${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-r${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ dev-ml/batteries:=
+ dev-ml/camlp-streams:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+ sci-mathematics/why3:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}