summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gimps')
-rw-r--r--sci-mathematics/gimps/Manifest2
-rw-r--r--sci-mathematics/gimps/gimps-30.3.6.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index cce833ef676f..83ee308a1345 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -1,2 +1,4 @@
DIST p95v298b6.linux32.tar.gz 5696871 BLAKE2B e2c68c4dac1e4cfbc2e44542665326d33a7929585928ca720569b918f5286c97b93acc45c03d0514cadb29e87e5c6ca103e69953417df8405e36998c5768896b SHA512 6f82973237c59cd548fe7bfc08c51a62cc7ac4e98a8539e5dfbc23eec21fb6f46e1534dc834852557af61fa1a6fc9b634d9117d85fce37f8f6f9189fb724518b
DIST p95v298b6.linux64.tar.gz 7032597 BLAKE2B de4de01d68caba4530d5adca165bfaa28cdb7e276b44355b200245cac6bab80bc05885a994c06331c2f66bdcd236c8bdb6cc8206ca40fb583bce6dc98eced7b1 SHA512 cb0ea195f4167e22bfdeef02872205a40ccd4d110abc9c354a413284db9aef1dbf9888ecdc3f09262e0d1033c0e4bed1f23d4d966fb58c437673a81095252bd1
+DIST p95v303b6.linux32.tar.gz 5702312 BLAKE2B 728c8b8e7e2b5187dc8126bccc5e2c165fbfbc0900d6c35517cd21b78e5292df143641e3766cc0146918062039b1eecab568f9b278f64b1b9197ee2f775603b9 SHA512 3e06fb77be07334949ece3ae152bdf5491f0b7f8e33e0e8ed2af3c34332841975a9514d1993ed2355abfa4e09f93e42093d02f96dc30c3471ae9f974cc2de11a
+DIST p95v303b6.linux64.tar.gz 7046127 BLAKE2B 9cde9c2670203071cfc463434a47c8123064cb232bfeb25d8767cad2c25ea75b395e2ec135b7b4a6dc9616e9d6b05ead371e1083274a82468f62a0e1de93c98f SHA512 6d6ded9a1724993d42adee28d400b0337835c52a4ce42271e62efb37134adfc6f017f55475860fbc1224e377a227ef8547b8852a35c082c37e996f4a1c1b570c
diff --git a/sci-mathematics/gimps/gimps-30.3.6.ebuild b/sci-mathematics/gimps/gimps-30.3.6.ebuild
new file mode 100644
index 000000000000..c5644dfa342a
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-30.3.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ x86? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+RESTRICT="mirror bindist"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}