summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/lrcalc/lrcalc-1.2.ebuild')
-rw-r--r--sci-mathematics/lrcalc/lrcalc-1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-mathematics/lrcalc/lrcalc-1.2.ebuild b/sci-mathematics/lrcalc/lrcalc-1.2.ebuild
new file mode 100644
index 000000000000..30805331116a
--- /dev/null
+++ b/sci-mathematics/lrcalc/lrcalc-1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Littlewood-Richardson Calculator"
+HOMEPAGE="https://sites.math.rutgers.edu/~asbuch/lrcalc/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2-includes.patch" )
+
+src_configure(){
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}