summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/primecount')
-rw-r--r--sci-mathematics/primecount/Manifest1
-rw-r--r--sci-mathematics/primecount/primecount-7.4.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
index 108b8d583077..1e26ee5dd234 100644
--- a/sci-mathematics/primecount/Manifest
+++ b/sci-mathematics/primecount/Manifest
@@ -1,2 +1 @@
-DIST primecount-7.4.tar.gz 372374 BLAKE2B ca16004e1a1fe209452d1c4aa9d4dfe7816ff581ffbb9717ae9a8224815df0b672871ec3d749000099a91c8ee50bcc3c43cea3dcb9ff999436544bed2c2f5fde SHA512 20b33a1c0d2338f422a0da8723bafd35689f9c93918c7dcf64068aee1cd5e03f41d0ef49e39a7e920828b478e8faeda4fea477dacca1145c852f24d1f5e6ab5b
DIST primecount-7.6.tar.gz 382074 BLAKE2B f665db8724b32b2f057db96fdd6421d7a996ed4bda7f43cd405e6c05b59abab8672407c41b6fafdd9c68dae3f51b65305112c0724c95ce3fdb33b9dbfaadfbff SHA512 643372d9a011dba8a49f21eabc00068b77a5ef5dc6d12e6b55230b97f14dc9d1d855bb7ad662beda548e4ff1396f1b06d473e2fe4b81e7dbe9926aaadc4da360
diff --git a/sci-mathematics/primecount/primecount-7.4.ebuild b/sci-mathematics/primecount/primecount-7.4.ebuild
deleted file mode 100644
index 457c9e552afa..000000000000
--- a/sci-mathematics/primecount/primecount-7.4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="Highly optimized CLI and library to count primes"
-HOMEPAGE="https://github.com/kimwalisch/primecount"
-SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0/7" # subslot is first component of libprimecount.so version
-KEYWORDS="amd64"
-IUSE="cpu_flags_x86_popcnt +executable openmp test"
-RESTRICT="!test? ( test )"
-
-DEPEND=">=sci-mathematics/primesieve-8.0:="
-RDEPEND="${DEPEND}"
-
-DOCS=(
- ChangeLog
- README.md
- doc/Credits.md
- doc/Easy-Special-Leaves.md
- doc/Hard-Special-Leaves.md
- doc/Records.md
- doc/References.md
- doc/alpha-factor-dr.pdf
- doc/alpha-factor-gourdon.pdf
- doc/alpha-factor-lmo.pdf
- doc/libprimecount.md
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_LIBPRIMESIEVE="OFF"
- -DBUILD_PRIMECOUNT="$(usex executable)"
- -DBUILD_STATIC_LIBS="OFF"
- -DBUILD_TESTS="$(usex test)"
- -DWITH_OPENMP="$(usex openmp)"
- -DWITH_POPCNT="$(usex cpu_flags_x86_popcnt)"
- )
-
- cmake_src_configure
-}