summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch76
1 files changed, 0 insertions, 76 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch b/sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch
deleted file mode 100644
index 28b0220912a0..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-Index: rstudio-1.1.357/src/cpp/session/CMakeLists.txt
-===================================================================
---- rstudio-1.1.357.orig/src/cpp/session/CMakeLists.txt
-+++ rstudio-1.1.357/src/cpp/session/CMakeLists.txt
-@@ -25,9 +25,6 @@ endif()
- if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-26")
- message(FATAL_ERROR "Mathjax 2.6 not found (re-run install-dependencies script to install)")
- endif()
--if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc")
-- message(FATAL_ERROR "pandoc not found (re-run install-dependencies script to install)")
--endif()
-
- # we often install embedded versions of these packages but don't do so currently
-
-@@ -38,22 +35,6 @@ endif()
- # message(FATAL_ERROR "rsconnect package not found (re-run install-dependencies script to install)")
- # endif()
-
--# verify libclang is installed
--if(WIN32)
-- set(LIBCLANG_VERSION "3.4")
--else()
-- set(LIBCLANG_VERSION "3.5")
--endif()
--set(LIBCLANG_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/${LIBCLANG_VERSION}")
--if(NOT EXISTS "${LIBCLANG_DIR}")
-- message(FATAL_ERROR "libclang ${LIBCLANG_VERSION} not found (re-run install-dependencies script to install)")
--endif()
--set(LIBCLANG_HEADERS_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers")
--if(NOT EXISTS "${LIBCLANG_HEADERS_DIR}")
-- message(FATAL_ERROR "libclang builtin-headers not found (re-run install-dependencies script to install)")
--endif()
--
--
- # include files
- file(GLOB_RECURSE SESSION_HEADER_FILES "*.h*")
-
-@@ -465,13 +446,6 @@ if (NOT RSTUDIO_SESSION_WIN64)
- install(DIRECTORY "resources/connections"
- DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
-
-- # install pandoc
-- set(PANDOC_BIN "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc/1.19.2.1")
-- file(GLOB PANDOC_FILES "${PANDOC_BIN}/pandoc*")
-- install(FILES ${PANDOC_FILES}
-- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
-- DESTINATION ${RSTUDIO_INSTALL_BIN}/pandoc)
--
- # install rmarkdown package
- # file(GLOB RMARKDOWN_PACKAGE "${RSTUDIO_DEPENDENCIES_DIR}/common/rmarkdown*.tar.gz")
- # install(FILES ${RMARKDOWN_PACKAGE}
-@@ -502,24 +476,6 @@ if (NOT RSTUDIO_SESSION_WIN64)
- install(DIRECTORY "resources/profiler"
- DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
-
-- # install libclang
-- if(WIN32)
-- file(GLOB LIBCLANG_32_FILES "${LIBCLANG_DIR}/x86/libclang.*")
-- install(PROGRAMS ${LIBCLANG_32_FILES}
-- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86)
-- file(GLOB LIBCLANG_64_FILES "${LIBCLANG_DIR}/x86_64/libclang.*")
-- install(PROGRAMS ${LIBCLANG_64_FILES}
-- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86_64)
-- else()
-- file(GLOB_RECURSE LIBCLANG_FILES "${LIBCLANG_DIR}/libclang.*")
-- install(PROGRAMS ${LIBCLANG_FILES}
-- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang)
-- endif()
--
-- # install libclang builtin-headers
-- install(DIRECTORY "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers"
-- DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources/libclang")
--
- # install winpty on windows
- if(WIN32)
- install(PROGRAMS "${WINPTY_BINDIR_32}/winpty.dll"