summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/xmds/xmds-1.6.6.ebuild')
-rw-r--r--sci-mathematics/xmds/xmds-1.6.6.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sci-mathematics/xmds/xmds-1.6.6.ebuild b/sci-mathematics/xmds/xmds-1.6.6.ebuild
deleted file mode 100644
index 9d3e48b854d2..000000000000
--- a/sci-mathematics/xmds/xmds-1.6.6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils
-
-doc_ver=20080226
-
-DESCRIPTION="XMDS - The eXtensible Multi-Dimensional Simulator"
-HOMEPAGE="http://www.xmds.org"
-SRC_URI="mirror://sourceforge/xmds/${P}.tar.gz
- doc? ( mirror://sourceforge/xmds/xmds_doc_${doc_ver}.pdf )"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples mpi threads"
-
-DEPEND="sci-libs/fftw
- mpi? ( virtual/mpi )"
-
-src_compile() {
- local my_opts=""
-
- if has_version "=sci-libs/fftw-3*" ; then
- my_opts="${my_opts} --enable-fftw3"
- fi
-
- econf \
- $(use_enable mpi) \
- $(use_enable threads) \
- ${my_opts} || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins "${DISTDIR}/xmds_doc_${doc_ver}.pdf"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- for i in "${D}"/usr/share/doc/${PN}/examples/* ; do
- doins "$i"
- done
- fi
-
- rm -rf "${D}/usr/share/doc/${PN}"
-}