summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild48
-rw-r--r--sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch12
2 files changed, 54 insertions, 6 deletions
diff --git a/sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild b/sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..5392bb9057f5
--- /dev/null
+++ b/sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DOC="${PN}-doc-1.5"
+
+DESCRIPTION="Interactive geometry package"
+HOMEPAGE="http://www.ofset.org/drgeo"
+SRC_URI="
+ mirror://sourceforge/ofset/${P}.tar.gz
+ mirror://sourceforge/ofset/${DOC}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ dev-scheme/guile:=[deprecated]
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc45.patch )
+
+src_configure() {
+ default
+ # Can't make the documentation as it depends on Hyperlatex which isn't
+ # yet in portage. Fortunately HTML is already compiled for us in the
+ # tarball and so can be installed. Just create the make install target.
+ cd "${WORKDIR}"/${DOC} || die
+ econf
+}
+
+src_install() {
+ sed -i -e "s/gnome-drgenius.png/${PN}/" \
+ -e '/^Categories=/s/Application;//' \
+ ${PN}.desktop || die
+ default
+ emake -C "${WORKDIR}"/${DOC}/$(usex nls "" c) DESTDIR="${D}" install
+ doicon glade/${PN}.png
+}
diff --git a/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch b/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
index 1d8e93e06fea..257cbb23d111 100644
--- a/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
+++ b/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
@@ -3,8 +3,8 @@ Fix build with GCC 4.5, fix random SIGSEGV
http://bugs.gentoo.org/show_bug.cgi?id=322211
https://bugzilla.redhat.com/show_bug.cgi?id=454045
---- geo/drgeo_figure.h
-+++ geo/drgeo_figure.h
+--- a/geo/drgeo_figure.h
++++ b/geo/drgeo_figure.h
@@ -322,4 +322,11 @@
gboolean showGrid;
};
@@ -17,8 +17,8 @@ https://bugzilla.redhat.com/show_bug.cgi?id=454045
+drgeoDialogData;
+
#endif
---- geo/drgeo_figure.cc
-+++ geo/drgeo_figure.cc
+--- a/geo/drgeo_figure.cc
++++ b/geo/drgeo_figure.cc
@@ -48,13 +48,6 @@
#include "drgeo_dialog.h"
#include "traite.h"
@@ -42,8 +42,8 @@ https://bugzilla.redhat.com/show_bug.cgi?id=454045
}
void
---- geo/drgeo_dialog.cc
-+++ geo/drgeo_dialog.cc
+--- a/geo/drgeo_dialog.cc
++++ b/geo/drgeo_dialog.cc
@@ -38,14 +38,6 @@
// Used in the style dialod callback, I know it's ugly, but so easy
static drgeoFigure *selected_figure;