summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/Manifest2
-rw-r--r--sci-mathematics/coq/coq-8.5_p1.ebuild97
-rw-r--r--sci-mathematics/coq/coq-8.5_p2.ebuild96
-rw-r--r--sci-mathematics/coq/files/oc43.patch13
4 files changed, 0 insertions, 208 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 9cf421cebdcc..b9eb71d7719c 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,5 +1,3 @@
DIST coq-8.5.tar.gz 5346653 SHA256 89a92fb8b91e7cb0797d41c87cd13e4b63bee76c32a6dcc3d7c8055ca6a9ae3d SHA512 28835a9dc4c926f97b14d23fe746e45e17942003e29807ec59f301eb0b697d704f05afc4cccd31b83bc27e9877d079d00e94a2101ba16ae32f4134e90ad011fb WHIRLPOOL 30925b92f71ba606e43f1b46368822e8d6f6e6c1ae500c8fe1fc912c4ef0608c6db3c070d37ffabbd0e054eac0ff7d1b1e46eae33b73149bf238101b20a0f6d2
-DIST coq-8.5pl1.tar.gz 5364928 SHA256 97047fc5e628f22e308efd3e86f625ae0504507decb96f2541e8e67eeaac20e8 SHA512 d907398e293cfc708c9314b3bbd57abf0806883cc1891d2b428f24e338953147586c0754e880fe679dfa893278335376287f6667db6c83dc7cb44a9e8afaddd1 WHIRLPOOL 7c65fd6a6804691492968d8b38cbbd34ac3fb9773cdea368679c206f735400d378e6d3786ce1955b22ac5ec4811beefaf83a6b656fb46a855e75c00c00608f21
-DIST coq-8.5pl2.tar.gz 5321862 SHA256 83239d1251bf6c54a9ca5045d738e469019b93ca601756bf982aab0654e4de73 SHA512 0a0c7678eb92bbf3328a9667c66ff3bf59bc7fa6dea790ac1e1b2f4a7ab3121fb1ff01d18c2fc1bed53455286d0c507fe73cfccc1680ed3a219e773ab299f3af WHIRLPOOL 89b632538fd10afd2257aaf2b0acb26f4d2d49a7492583c039f88df6876ac27fc804b5854ee353d98cda64c2da3bf5571d7b9fde1cb9ceb50a90769633de18c7
DIST coq-8.5pl3.tar.gz 5335502 SHA256 305b92e05d406d4d0c64f43d4fadb6b89419120a1d4ae4115ed1c5eb8812d33b SHA512 3093c71769135479526a6ffea05929fe640046fd376e4369a0f8308915d0eeac3330a62d3309bd062a9dd46739bd2497d43e4885ed188a8e4d9b7ca016e89402 WHIRLPOOL 95798242e7b808776f97c3c7896c100f89bacba4978c7179b6275a02c1db9ab8f3c01a823ba5d9d276ca5defabea24db296e70dc2ac9525ec64aa88dead94281
DIST coq-8.6.tar.gz 5538848 SHA256 6e3c3cf5c8e2b0b760dc52738e2e849f3a8c630869659ecc0cf41413fcee81df SHA512 9f5f4913fda8cf83683fec9398b42d4567207c3d4b52b4638d5e09a24ed25a43905fb57a9fac1bb9f9d681bd47f3560e1da74e79348b3a3fd93e2e8c686cebae WHIRLPOOL 714226c0f9138ea7dc9828db6dbc59e9b6e0c18ae305fc1a67c5c1c7a950ec1deabd37f462e20d1d1ddbd148a8bc3845a72f88f5ef6cbd4f93abfd02539dbcbc
diff --git a/sci-mathematics/coq/coq-8.5_p1.ebuild b/sci-mathematics/coq/coq-8.5_p1.ebuild
deleted file mode 100644
index b1cc46702a3b..000000000000
--- a/sci-mathematics/coq/coq-8.5_p1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils multilib
-
-MY_PV=${PV/_p/pl}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="http://${PN}.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gtk debug +ocamlopt doc camlp5"
-
-RDEPEND="
- >=dev-lang/ocaml-3.11.2:=[ocamlopt?]
- camlp5? ( >=dev-ml/camlp5-6.02.3:=[ocamlopt?] )
- !camlp5? ( dev-ml/camlp4:= )
- gtk? ( >=dev-ml/lablgtk-2.10.1:=[sourceview,ocamlopt?] )"
-DEPEND="${RDEPEND}
- doc? (
- media-libs/netpbm[png,zlib]
- virtual/latex-base
- dev-tex/hevea
- dev-tex/xcolor
- dev-texlive/texlive-pictures
- dev-texlive/texlive-mathextra
- dev-texlive/texlive-latexextra
- )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-8.5-do-not-install-revision.patch"
- epatch "${FILESDIR}/${PN}-8.4_p5-no-clean-before-test.patch"
- has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
-}
-
-src_configure() {
- ocaml_lib=$(ocamlc -where)
- local myconf=(
- -prefix /usr
- -bindir /usr/bin
- -libdir /usr/$(get_libdir)/coq
- -mandir /usr/share/man
- -emacslib /usr/share/emacs/site-lisp
- -coqdocdir /usr/$(get_libdir)/coq/coqdoc
- -docdir /usr/share/doc/${PF}
- -configdir /etc/xdg/${PN}
- -lablgtkdir ${ocaml_lib}/lablgtk2
- )
-
- use debug && myconf+=( -debug )
- use doc || myconf+=( -with-doc no )
-
- if use gtk; then
- if use ocamlopt; then
- myconf+=( -coqide opt )
- else
- myconf+=( -coqide byte )
- fi
- else
- myconf+=( -coqide no )
- fi
-
- use ocamlopt || myconf+=( -byte-only )
-
- if use camlp5; then
- myconf+=( -usecamlp5 -camlp5dir ${ocaml_lib}/camlp5 )
- else
- myconf+=( -usecamlp4 )
- fi
-
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
- ./configure ${myconf[@]} || die "configure failed"
-}
-
-src_compile() {
- emake STRIP="true" -j1 world VERBOSE=1
-}
-
-src_test() {
- emake STRIP="true" check VERBOSE=1
-}
-
-src_install() {
- emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
- dodoc README CREDITS CHANGES
-
- use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
-}
diff --git a/sci-mathematics/coq/coq-8.5_p2.ebuild b/sci-mathematics/coq/coq-8.5_p2.ebuild
deleted file mode 100644
index 5e04286444d7..000000000000
--- a/sci-mathematics/coq/coq-8.5_p2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils multilib
-
-MY_PV=${PV/_p/pl}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="http://${PN}.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gtk debug +ocamlopt doc camlp5"
-
-RDEPEND="
- >=dev-lang/ocaml-3.11.2:=[ocamlopt?]
- camlp5? ( >=dev-ml/camlp5-6.02.3:=[ocamlopt?] )
- !camlp5? ( dev-ml/camlp4:= )
- gtk? ( >=dev-ml/lablgtk-2.10.1:=[sourceview,ocamlopt?] )"
-DEPEND="${RDEPEND}
- doc? (
- media-libs/netpbm[png,zlib]
- virtual/latex-base
- dev-tex/hevea
- dev-tex/xcolor
- dev-texlive/texlive-pictures
- dev-texlive/texlive-mathextra
- dev-texlive/texlive-latexextra
- )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-8.5-do-not-install-revision.patch"
- epatch "${FILESDIR}/${PN}-8.4_p5-no-clean-before-test.patch"
-}
-
-src_configure() {
- ocaml_lib=$(ocamlc -where)
- local myconf=(
- -prefix /usr
- -bindir /usr/bin
- -libdir /usr/$(get_libdir)/coq
- -mandir /usr/share/man
- -emacslib /usr/share/emacs/site-lisp
- -coqdocdir /usr/$(get_libdir)/coq/coqdoc
- -docdir /usr/share/doc/${PF}
- -configdir /etc/xdg/${PN}
- -lablgtkdir ${ocaml_lib}/lablgtk2
- )
-
- use debug && myconf+=( -debug )
- use doc || myconf+=( -with-doc no )
-
- if use gtk; then
- if use ocamlopt; then
- myconf+=( -coqide opt )
- else
- myconf+=( -coqide byte )
- fi
- else
- myconf+=( -coqide no )
- fi
-
- use ocamlopt || myconf+=( -byte-only )
-
- if use camlp5; then
- myconf+=( -usecamlp5 -camlp5dir ${ocaml_lib}/camlp5 )
- else
- myconf+=( -usecamlp4 )
- fi
-
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
- ./configure ${myconf[@]} || die "configure failed"
-}
-
-src_compile() {
- emake STRIP="true" -j1 world VERBOSE=1
-}
-
-src_test() {
- emake STRIP="true" check VERBOSE=1
-}
-
-src_install() {
- emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
- dodoc README CREDITS CHANGES
-
- use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
-}
diff --git a/sci-mathematics/coq/files/oc43.patch b/sci-mathematics/coq/files/oc43.patch
deleted file mode 100644
index 47fa10ab575e..000000000000
--- a/sci-mathematics/coq/files/oc43.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: coq-8.5pl1/Makefile.common
-===================================================================
---- coq-8.5pl1.orig/Makefile.common
-+++ coq-8.5pl1/Makefile.common
-@@ -231,7 +231,7 @@ endif
- LINKCMO:=$(CORECMA) $(STATICPLUGINS)
- LINKCMX:=$(CORECMA:.cma=.cmxa) $(STATICPLUGINS:.cma=.cmxa)
-
--IDEDEPS:=lib/clib.cma lib/xml_lexer.cmo lib/xml_parser.cmo lib/xml_printer.cmo lib/errors.cmo lib/spawn.cmo
-+IDEDEPS:=lib/clib.cma lib/errors.cmo lib/spawn.cmo
- IDECMA:=ide/ide.cma
- IDETOPLOOPCMA=ide/coqidetop.cma
-