summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gap/Manifest1
-rw-r--r--sci-mathematics/gap/gap-4.12.2.ebuild78
-rw-r--r--sci-mathematics/gap/metadata.xml35
3 files changed, 114 insertions, 0 deletions
diff --git a/sci-mathematics/gap/Manifest b/sci-mathematics/gap/Manifest
new file mode 100644
index 000000000000..20d1f3a3316c
--- /dev/null
+++ b/sci-mathematics/gap/Manifest
@@ -0,0 +1 @@
+DIST gap-4.12.2-core.tar.gz 37671069 BLAKE2B 7e2c35f0bb232fc5478ff09e98b9c4d021ee5df775f2ff4934b27f871c18a3781386c24b94f1255517c4193c1eb9ff6396ea70e8d6cf72ccbb5480ca837ef8eb SHA512 d16af2648b0a655df7ce28cf8e2c6b3d0e33eda806674844a9813b4cb5068b137005225c02b8651a25b608e9b76a184f54f2e291a957a4675c38a7883ef83a38
diff --git a/sci-mathematics/gap/gap-4.12.2.ebuild b/sci-mathematics/gap/gap-4.12.2.ebuild
new file mode 100644
index 000000000000..4a74d2e9e3cf
--- /dev/null
+++ b/sci-mathematics/gap/gap-4.12.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="System for computational discrete algebra. Core functionality."
+HOMEPAGE="https://www.gap-system.org/"
+SRC_URI="https://github.com/gap-system/gap/releases/download/v${PV}/${P}-core.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/8"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_popcnt debug emacs memcheck readline valgrind"
+REQUIRED_USE="?? ( memcheck valgrind )"
+RESTRICT=test
+
+DEPEND="dev-libs/gmp:=
+ sys-libs/zlib
+ valgrind? ( dev-util/valgrind )
+ readline? ( sys-libs/readline:= )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use valgrind; then
+ elog "If you enable the use of valgrind during building"
+ elog "be sure that you have enabled the proper flags"
+ elog "in gcc to support it:"
+ elog "https://wiki.gentoo.org/wiki/Debugging#Valgrind"
+ fi
+}
+
+src_prepare() {
+ # Remove these to be extra sure we don't use bundled libraries.
+ rm -r extern || die
+ rm -r hpcgap/extern || die
+
+ # The Makefile just tells you to run ./configure, which then
+ # produces a GNUmakefile.
+ rm Makefile || die
+
+ default
+
+ # Fix feature detection with pathological CFLAGS
+ eautoreconf
+}
+
+src_configure() {
+ # We unset $ABI because GAP uses it internally for something else.
+ # --without-gmp and --without-zlib both trigger an AC_MSG_ERROR
+ econf \
+ ABI="" \
+ --with-gmp \
+ --with-zlib \
+ $(use_enable cpu_flags_x86_popcnt popcnt) \
+ $(use_enable memcheck memory-checking) \
+ $(use_enable valgrind) \
+ $(use_with readline) \
+ $(use_enable debug)
+}
+
+src_compile() {
+ # Without this, the default is a quiet build.
+ emake V=1
+}
+
+src_install() {
+ default
+
+ # Manually install Makefile.gappkg
+ insinto usr/share/gap/etc
+ doins etc/Makefile.gappkg
+
+ # la files removal
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/sci-mathematics/gap/metadata.xml b/sci-mathematics/gap/metadata.xml
new file mode 100644
index 000000000000..26c5fc567f82
--- /dev/null
+++ b/sci-mathematics/gap/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Groups, Algorithms, Programming is a system for computational
+ discrete algebra, with particular emphasis on Computational Group
+ Theory. GAP provides a programming language, a library of thousands
+ of functions implementing algebraic algorithms written in the GAP
+ language as well as large data libraries of algebraic objects. GAP
+ is used in research and teaching for studying groups and their
+ representations, rings, vector spaces, algebras, combinatorial
+ structures, and more.
+ </longdescription>
+ <use>
+ <flag name="memcheck">Enable memory checking</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">gap-system/gap</remote-id>
+ </upstream>
+</pkgmetadata>