summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/yices2/Manifest1
-rw-r--r--sci-mathematics/yices2/metadata.xml26
-rw-r--r--sci-mathematics/yices2/yices2-2.6.4.ebuild47
3 files changed, 74 insertions, 0 deletions
diff --git a/sci-mathematics/yices2/Manifest b/sci-mathematics/yices2/Manifest
new file mode 100644
index 000000000000..c1bd9e2d494e
--- /dev/null
+++ b/sci-mathematics/yices2/Manifest
@@ -0,0 +1 @@
+DIST Yices-2.6.4.tar.gz 10186909 BLAKE2B 1c4b6297fd59924e9d99b9e17eb4b42e9bfbc24dcd56631beb9b72103c91578eb72b90cb9e228a5e9d489efc520a2e1d41185e9c3f4a8c43fc93f8dabba7414d SHA512 d8102c41fda0e200fd1336ae317b516d2797d10c187b8f7aecf0c9b08b4b487b90bef8c358099b2da51c0367326939f9610fd4e6d5a41a392cf1114bd04b8763
diff --git a/sci-mathematics/yices2/metadata.xml b/sci-mathematics/yices2/metadata.xml
new file mode 100644
index 000000000000..0b8f70011239
--- /dev/null
+++ b/sci-mathematics/yices2/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Yices 2 is an SMT solver that decides the satisfiability of formulas
+ containing uninterpreted function symbols with equality, real and integer
+ arithmetic, bitvectors, scalar types, and tuples. Yices 2 supports both
+ linear and nonlinear arithmetic. Yices 2 can process input written in the
+ SMT-LIB notation (both versions 2.0 and 1.2 are supported). Alternatively,
+ you can write specifications using Yices 2's own specification language,
+ which includes tuples and scalar types. You can also use Yices 2 as a
+ library in your software.
+ </longdescription>
+ <use>
+ <flag name="mcsat">Enable support for MCSAT</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/SRI-CSL/yices2/issues/</bugs-to>
+ <remote-id type="github">SRI-CSL/yices2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/yices2/yices2-2.6.4.ebuild b/sci-mathematics/yices2/yices2-2.6.4.ebuild
new file mode 100644
index 000000000000..8fcf3fcb619b
--- /dev/null
+++ b/sci-mathematics/yices2/yices2-2.6.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="SMT Solver supporting SMT-LIB and Yices specification language"
+HOMEPAGE="https://github.com/SRI-CSL/yices2/"
+SRC_URI="https://github.com/SRI-CSL/${PN}/archive/Yices-${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-Yices-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mcsat"
+
+RDEPEND="
+ dev-libs/gmp:=
+ mcsat? (
+ sci-mathematics/libpoly:=
+ sci-mathematics/cudd:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( FAQ.md README.md )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable mcsat)
+}
+
+src_compile() {
+ emake STRIP=echo
+}
+
+src_install() {
+ default
+
+ doman doc/*.1
+}