summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/why3/Manifest1
-rw-r--r--sci-mathematics/why3/why3-1.4.1-r1.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/sci-mathematics/why3/Manifest b/sci-mathematics/why3/Manifest
index b4c557cc84db..38a095398b28 100644
--- a/sci-mathematics/why3/Manifest
+++ b/sci-mathematics/why3/Manifest
@@ -1,3 +1,2 @@
-DIST why3-1.4.1.tar.gz 6305011 BLAKE2B 2d916fbf333550f8021bff9e7ccf4ca5685763ca7f82ae133298feaf96f3e8b36290a103fd27224fb6fb2dc36c8d7ad5d93ffc92e8cf7fe1a61abb5a40aecb39 SHA512 7990519179c088be1bc9b5b6d469f6d6fbd683445e20cbf5edd5c97682f2931b2657a92b60e539d7647033bfdc5a63401f28af61fd9b14b41011144afa2016e0
DIST why3-1.5.1.tar.gz 6727576 BLAKE2B db88dc011856bc779a917613adb20c14744f5491aba54e424909106a1133362ddf9eb22e4a05660cb3153bfddfa54c488e1f9df046e3c413732924e127975e82 SHA512 1452a21ea9191f57debcc082afe458aec503d6aa24f8bc83f734041cdd302c4f166c9c4fe5f9ec25369b6e83011bdd7b485d67b092efa71ff0c1b39447f4bdac
DIST why3-1.6.0.tar.gz 6850062 BLAKE2B 91db6f67a9d0fe24b7d7d18e6c5e9cd362563a55702bfb28c478754f53e831beb3033adde251214facd8d64ab923389b0b9fe7b240b6cd09f0b4b3e6f8eca143 SHA512 60d61b8337ab9f2fd2e6c7174eb0bab063f122417738cd75990c5c53120dd535bcedccb670567f5753853d6bc9f8efebb563d079e4d368372a7687193f1346b1
diff --git a/sci-mathematics/why3/why3-1.4.1-r1.ebuild b/sci-mathematics/why3/why3-1.4.1-r1.ebuild
deleted file mode 100644
index 6d1e01d9863c..000000000000
--- a/sci-mathematics/why3/why3-1.4.1-r1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools findlib
-
-DESCRIPTION="Platform for deductive program verification"
-HOMEPAGE="https://why3.lri.fr/"
-SRC_URI="https://why3.gitlabpages.inria.fr/releases/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="coq doc emacs gtk +ocamlopt re sexp +zarith zip"
-
-RDEPEND="
- !sci-mathematics/why3-for-spark
- >=dev-lang/ocaml-4.05.0:=[ocamlopt?]
- >=dev-ml/menhir-20170418:=
- dev-ml/num:=
- coq? ( >=sci-mathematics/coq-8.6 )
- emacs? ( app-editors/emacs:* )
- gtk? ( dev-ml/lablgtk:=[sourceview,ocamlopt?] )
- re? ( dev-ml/re:= )
- sexp? (
- dev-ml/ppx_deriving:=[ocamlopt?]
- dev-ml/ppx_sexp_conv:=[ocamlopt?]
- dev-ml/sexplib:=[ocamlopt?]
- )
- zarith? ( dev-ml/zarith:= )
- zip? ( dev-ml/camlzip:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- dev-python/sphinx
- dev-python/sphinxcontrib-bibtex
- media-gfx/graphviz
- dev-texlive/texlive-latex
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- )
-"
-
-DOCS=( CHANGES.md README.md )
-
-src_prepare() {
- mv configure.in configure.ac || die
- sed -i 's/configure\.in/configure.ac/g' Makefile.in || die
- sed -e '/^lib\/why3[a-z]*\$(EXE):/{n;s/-Wall/$(CFLAGS) $(LDFLAGS)/}' \
- -e '/^%.o: %.c/{n;s/\$(CC).*-o/$(CC) $(CFLAGS) -o/}' \
- -e '/\$(SPHINX)/s/ -d doc\/\.doctrees / /' \
- -i Makefile.in || die
-
- eautoreconf
- default
-}
-
-src_configure() {
- local myconf=(
- --disable-hypothesis-selection
- --disable-pvs-libs
- --disable-isabelle-libs
- --disable-frama-c
- --disable-infer
- --disable-web-ide
- $(use_enable coq coq-libs)
- $(use_enable doc)
- $(use_enable emacs emacs-compilation)
- $(use_enable gtk ide)
- $(use_enable ocamlopt native-code)
- $(use_enable re)
- $(use_enable sexp pp-sexp)
- $(use_enable zarith)
- $(use_enable zip)
- )
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake
- emake plugins
- use doc && emake doc
-}
-
-src_install(){
- findlib_src_preinst
- emake install install-lib DESTDIR="${ED}"
-
- einstalldocs
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- if use doc; then
- dodoc doc/latex/manual.pdf
- dodoc -r doc/html
- fi
-}