summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pspp/Manifest1
-rw-r--r--sci-mathematics/pspp/pspp-0.10.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/pspp/Manifest b/sci-mathematics/pspp/Manifest
index 7417e1e91460..2a524b4ebe3c 100644
--- a/sci-mathematics/pspp/Manifest
+++ b/sci-mathematics/pspp/Manifest
@@ -1,3 +1,4 @@
DIST pspp-0.10.1.tar.gz 7269109 SHA256 44cc08864de736880bc0d7e2b1f8c8493ac0e0c2164a4f9471077608f00c8677 SHA512 a7f4eec3858340743ff845e67028af76d79a58968ceaa19a87e0443751917b2d70251e53231ecce15c937c9640ac733e00603baa76b4266d693375ab70b870b5 WHIRLPOOL 9a195051d5279a86cd05d586ca5a845443f08346f47aec859a3e768c38d5517f23f47d40cc6fb00c6af6c01af624d251575edfb34dfb0f7c7ee3def1a008a1c7
+DIST pspp-0.10.2.tar.gz 7316470 SHA256 f77cacae6948689a60f1a5808a5d2e183c1cd0847c7fc6142646c63814c0daa9 SHA512 7d6656c03da46b088e87cba7a947d1e56031ff50d704be8201a38563515cf5cf324a05f1d4999ba8aec7b2269a8fdbd09374a11374c9c1b9dd6d78d34fda4b76 WHIRLPOOL f66f0ca98dce4de4b323aa42445d0c8fe3c7d252cd8ed6d1ad1dd961186bf063b9c92114a92e9afb2149b35c03fa595720c8a35b33ff81a56eb5e9e029c85119
DIST pspp-0.8.1.tar.gz 6514528 SHA256 fd48145d2ff77c39f624e26bf3c9a5623c2afaee7c040675b06cb4ce57d31d62 SHA512 2df758b3a2d8eba724d84ce7d77a6c0bbe469a11b86a8eb4227ec12a4957f468e74b3af0f81c953d87403a962937eef2680979a21ceba4fe8b93b55252b84a18 WHIRLPOOL 5be6ebcecffc3d8a7da669ea49028307b784a5b8b5d8a510d0f9e82a3740800966da5390f8abc120b55c9c621850be906f7610f86404b92c994d9a72697d413d
DIST pspp-0.8.3.tar.gz 6247760 SHA256 adb8de281098b0d8632a8f2ea2af6514100786cf946f07a3c268d4baff15316f SHA512 7645a2de09ed1d6f1a53900961791b64b9420f457278d19e62ca7dabdb02b01ee78cdab0efddae384dc7deff65f7c5256227538caed89537efa014437937a61c WHIRLPOOL cff5921acce8bb3654ab0d10d63c42af8d5a9745263f423900ee290a30f1748aff023739ba49fabca33517e3deaf3fb0513a5fac7d0cf50170ba4b870d0ededf
diff --git a/sci-mathematics/pspp/pspp-0.10.2.ebuild b/sci-mathematics/pspp/pspp-0.10.2.ebuild
new file mode 100644
index 000000000000..bcaea41c6013
--- /dev/null
+++ b/sci-mathematics/pspp/pspp-0.10.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils elisp-common
+
+DESCRIPTION="Program for statistical analysis of sampled data"
+HOMEPAGE="https://www.gnu.org/software/pspp/pspp.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cairo doc emacs examples gtk ncurses nls perl postgres static-libs"
+
+RDEPEND="
+ dev-libs/libxml2:2=
+ sci-libs/gsl:0=
+ sys-devel/gettext:0=
+ sys-libs/readline:0=
+ sys-libs/zlib:0=
+ virtual/libiconv
+ cairo? ( x11-libs/cairo:0=[svg] )
+ emacs? ( virtual/emacs )
+ gtk? (
+ x11-libs/gtk+:3=
+ x11-libs/gtksourceview:3.0= )
+ ncurses? ( sys-libs/ncurses:0= )
+ postgres? ( dev-db/postgresql:=[server] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_with cairo) \
+ $(use_with gtk gui) \
+ $(use_with ncurses libncurses) \
+ $(use_with perl perl-module) \
+ $(use_with postgres libpq)
+}
+
+src_compile() {
+ default
+ use doc && emake html pdf
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ default
+ if use doc; then
+ dodoc doc/pspp{,-dev}.pdf
+ insinto /usr/share/doc/${PF}/html
+ dodoc -r doc/pspp{,-dev}.html
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ prune_libtool_files --all
+}
+
+pkg_postinst () {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}