summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/nco/Manifest1
-rw-r--r--sci-misc/nco/nco-5.1.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-misc/nco/Manifest b/sci-misc/nco/Manifest
index 5d9f8e4e9e04..972fa14c834a 100644
--- a/sci-misc/nco/Manifest
+++ b/sci-misc/nco/Manifest
@@ -1 +1,2 @@
DIST nco-4.5.1.tar.gz 4406757 BLAKE2B f2e203f1c38f5575fe4affb9122c91c61db8a2c2604cbcf9cd1eec6330e4771b8ff4325fcc19cfa292508e9b7a3107ae20e6230397f1269441e4efb883f8e4e9 SHA512 69c19cc9502272adada329dae669fc1c263a360789963253315e81ce1534647b9172b39a0fd3c0f0f453bf903c8a8a4b0e3f0eb778390e43b64eede3a0478485
+DIST nco-5.1.3.tar.gz 6438534 BLAKE2B 6296d881b0e0b62e18daa40db71ccca79b4cca9fa8f046a0664f53b690d8f85175676900d792a4691090662ed80ce5c4e32e4236c69c6057d292800bd9987f36 SHA512 c4819a0b3a1c431419df73250e6648e5afc55439d260d166fb4e13ca3f4ae34bdc728b921922e075c86f6bf5dbede1565741616b2b9a32bcdcfbe85617a7f8ec
diff --git a/sci-misc/nco/nco-5.1.3.ebuild b/sci-misc/nco/nco-5.1.3.ebuild
new file mode 100644
index 000000000000..09b909e232be
--- /dev/null
+++ b/sci-misc/nco/nco-5.1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command line utilities for operating on netCDF files"
+HOMEPAGE="http://nco.sourceforge.net/"
+SRC_URI="http://nco.sf.net/src/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dap gsl hdf5 ncap2 openmp test udunits"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=sci-libs/netcdf-4:=[dap=,hdf5?,tools]
+ gsl? ( sci-libs/gsl:= )
+ ncap2? ( dev-cpp/antlr-cpp:2= )
+ udunits? ( >=sci-libs/udunits-2 )"
+DEPEND="${RDEPEND}
+ test? ( >=sci-libs/netcdf-4[tools] )"
+BDEPEND="sys-apps/texinfo"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ econf \
+ --disable-udunits \
+ --disable-gpu \
+ --enable-doc \
+ $(use_enable dap) \
+ $(use_enable gsl) \
+ $(use_enable hdf5 netcdf4) \
+ $(use_enable hdf5 netcdf-4) \
+ $(use_enable ncap2) \
+ $(use_enable ncap2 ncoxx) \
+ $(use_enable openmp) \
+ $(use_enable udunits udunits2)
+}
+
+src_install() {
+ default
+ dodoc doc/ChangeLog
+
+ find "${ED}" -name '*.la' -delete || die
+}