summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild b/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
index 6120fae9e88b..a5abe4c0c16b 100644
--- a/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
+++ b/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib versionator
+inherit desktop multilib versionator
DESCRIPTION="Wolfram Player for the interactive Computable Document Format (CDF)"
SRC_URI="WolframPlayer_12.2.0_LINUX.sh"
@@ -70,12 +70,12 @@ src_install() {
dosym ../Wolfram/${MPN}/${MPV}/Executables/WolframPlayer opt/bin/WolframPlayer
# fix some embedded paths and install desktop files
- insinto /usr/share/applications
+ local filename
for filename in $(find "${D}" -name "wolfram-cdf12.desktop") ; do
echo Fixing "${filename}"
sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
- doins "${filename}"
+ domenu "${filename}"
done
# install a wrapper