summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/espresso/espresso-9999.ebuild')
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild31
1 files changed, 16 insertions, 15 deletions
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index fcc6fbc9926e..ef5f6578edce 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
-CMAKE_MAKEFILE_GENERATOR="ninja"
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils python-single-r1 savedconfig
+inherit cmake python-single-r1 savedconfig
DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
HOMEPAGE="http://espressomd.org"
@@ -48,9 +48,11 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README ChangeLog )
+S="${WORKDIR}/${PN}"
+
src_prepare() {
use cuda && cuda_src_prepare
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -63,35 +65,34 @@ src_configure() {
-DWITH_HDF5=$(usex hdf5)
-DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
-DCMAKE_SKIP_RPATH=YES
- -DLIBDIR=$(get_libdir)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doxygen
- [[ ${PV} = 9999 ]] && use doc && cmake-utils_src_make ug dg tutorials
+ cmake_src_compile
+ use doc && cmake_build doxygen
+ [[ ${PV} = 9999 ]] && use doc && cmake_build ug dg tutorials
}
src_install() {
local i docdir="${S}"
- cmake-utils_src_install
+ cmake_src_install
insinto /usr/share/${PN}/
- doins ${CMAKE_BUILD_DIR}/myconfig-sample.hpp
+ doins "${BUILD_DIR}/myconfig-sample.hpp"
- save_config ${CMAKE_BUILD_DIR}/src/core/myconfig-final.hpp
+ save_config "${BUILD_DIR}/src/config/myconfig-final.hpp"
if use doc; then
- [[ ${PV} = 9999 ]] && docdir="${CMAKE_BUILD_DIR}"
+ [[ ${PV} = 9999 ]] && docdir="${BUILD_DIR}"
newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
newdoc "${i}" "tutorial_${i##*/}"
done
- dodoc -r ${CMAKE_BUILD_DIR}/doc/doxygen/html
+ dodoc -r "${BUILD_DIR}/doc/doxygen/html"
fi
if use examples; then