summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lammps/Manifest1
-rw-r--r--sci-physics/lammps/lammps-20160407.ebuild218
2 files changed, 219 insertions, 0 deletions
diff --git a/sci-physics/lammps/Manifest b/sci-physics/lammps/Manifest
index 3c25d6e24706..a34ea71aff69 100644
--- a/sci-physics/lammps/Manifest
+++ b/sci-physics/lammps/Manifest
@@ -10,6 +10,7 @@ DIST lammps-20Nov15.tar.gz 90227651 SHA256 7c392c848e73335226b2fef6bb8034b1152f9
DIST lammps-21Mar16.tar.gz 88654277 SHA256 c2f627db22f332995d90521f0e8d8e9865b85b49cde0ed4bcf727bf4b9b12767 SHA512 27e4a3a0c2c17fb9c85716b499ca2b3de8b0a699891afd32c8409117a0fbe27f1bd84ef16288cc5abda87ee8a7b1059960d8caed5aa339f54290aabeff0fdd4d WHIRLPOOL 370f79af4a8e55851aa0c071d02baddaade991a3208fe504f8b92796bbdb9b17b85af898a71177bbc67d885ffdef9280621c9b7f4bc22cdb14808332cb2eccb8
DIST lammps-22Jan16.tar.gz 85952234 SHA256 46425bf0ae73f716195a29dc9823c2c5989504f85b49a316bc304caaf6e6a674 SHA512 3ceeeaf76621bbc11ea25d5fb321b602b34ffb3893898a704b02e5cd428a36b2017006fdc1f7b1c5f957c33f26ca103a2939538ae7937555e0b25b5852cd48f3 WHIRLPOOL 7f61ea1924eceb190b7cf56ed32db75f6a45c99dbf1522862124f59acd1f79b1a46310d5e31a988011461a55c319677eaec2bf713e9a5cda0411b5d2280aa784
DIST lammps-6Nov15.tar.gz 90177074 SHA256 b908d87106e89aa813c3d1a2e89f297ab42471ee463ef950f87f284d62aa24ac SHA512 91f8e33a00b3605dbb78f622a19886c11ca8ef3f4babe74e8d8f90bb176d5689e75d619155f58e6754a2756d20c05b74389e34f024167cba1841b8aade171daf WHIRLPOOL 4541537ea73292648764d6c8a7560f3127b8f911f4dcff0a97735c8e75868dc3aec7c2b32a2928ea446e8cfec87c81c9f86a635d29f3a65f42fd27661725911e
+DIST lammps-7Apr16.tar.gz 88791123 SHA256 f87c11cbbdbbb64a337e0608ae0fde11f77d9b32d081a8095376db9bbecc6d5f SHA512 1045f0337b37a19760718a2b3b48d31608248069a8fb2dc43daf555e44e720db770ff53e2a2db09c3e1f2703bb98894516229382c810ce45cca3647f353a21cd WHIRLPOOL 4ed6e93efff84888f982aec4c55adff6eda94fec5608e473fe821f77ea7a867fa7de23cf54fe28007b61304e41c9d7e42f4994e455bfb67cfadf79dbfc019e0b
DIST lammps-7Dec15.tar.gz 82168656 SHA256 7fa1bb1089437c0f38f8c6920286e2f8424e6449956b4d570da2954f507af1e7 SHA512 13078e7614402efc310a178506134409b40fb2768c4d7ee1cfa6992b247ef25169288ec99d4314b1a98125037d7c1c954bd114abc6ac41c58f60506358d150e2 WHIRLPOOL f9ba52c0c93ea6950b2ee7e0f5e15ebef6ea50f647d23cb2f9a1caf523d3dfb8d52adbdf8f8840eebd7f79fc59ab294310b7bf7109b27c6b7e9d6e7d2f18b7ee
DIST lammps-8Dec15.tar.gz 90700099 SHA256 1782a856dcba1696e6e921d891f259e525de750d7cf39ce9457a1992ee4db91f SHA512 0382683a363975bd27cc1722932cd5b8eda9933bc9c676af135d7e4d784acd93cf60b2b47a19dbb9e4a05e5cf2fbf6ccc2c2a914c39e92e87009e23ead2eb497 WHIRLPOOL dca88d8d55e96c20702856b2074d631ef8f6a0f6209672e612778209ad188c800a673e09605033851349b400241b1f7c8e5e05bad49519838abfe5fe44467c43
DIST lammps-9Dec15.tar.gz 82374079 SHA256 36f918174826a80f54e65779ec939e185e81c71f747cb1524e43c58b1869491a SHA512 a35ef5b3ee99162b96ce1a6d6cc3b0dc18bab7f693b824fc7ad52a7477234ed45c3081c399155725f1ebc3bd1bed312176f08d3fc807e7099d4b41b8f75fd11c WHIRLPOOL 045d817e6a2c74fa2f4a5eb337328d6d9183fcedca44a1e608c59bd83fd4086763ff4d6ebed3715ba23cbde04f1233ef3e4a8e3e964ff3af3744c70580b51d0b
diff --git a/sci-physics/lammps/lammps-20160407.ebuild b/sci-physics/lammps/lammps-20160407.ebuild
new file mode 100644
index 000000000000..d3fac3072f78
--- /dev/null
+++ b/sci-physics/lammps/lammps-20160407.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils flag-o-matic fortran-2 multilib python-r1
+
+convert_month() {
+ local months=( "" Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec )
+ echo ${months[${1#0}]}
+}
+
+MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}
+
+DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
+HOMEPAGE="http://lammps.sandia.gov/"
+SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gzip lammps-memalign mpi python static-libs"
+
+# blas/lapack is needed by the ATC package which is only built with MPI.
+DEPEND="
+ gzip? ( app-arch/gzip )
+ mpi? (
+ virtual/mpi
+ )
+ python? ( ${PYTHON_DEPS} )
+ sci-libs/voro++
+ virtual/blas
+ virtual/lapack
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+lmp_emake() {
+ local LAMMPS_INCLUDEFLAGS
+ LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
+ LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN=64' '')"
+
+ # The lammps makefile uses CC to indicate the C++ compiler.
+ emake \
+ ARCHIVE="$(tc-getAR)" \
+ CC="$(usex mpi "mpic++" "$(tc-getCXX)")" \
+ F90="$(usex mpi "mpif90" "$(tc-getFC)")" \
+ LINK="$(usex mpi "mpic++" "$(tc-getCXX)")" \
+ CCFLAGS="${CXXFLAGS}" \
+ F90FLAGS="${FCFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
+ MPI_INC="$(usex mpi "" "-I../STUBS")" \
+ MPI_PATH="$(usex mpi "" "-L../STUBS")" \
+ MPI_LIB="$(usex mpi "" "-lmpi_stubs")" \
+ user-atc_SYSLIB="$(usex mpi "$($(tc-getPKG_CONFIG) --libs blas) $($(tc-getPKG_CONFIG) --libs lapack)" '')"\
+ "$@"
+}
+
+lmp_activate_packages() {
+ # Build packages
+ local packages=( yes-asphere yes-body yes-class2 yes-colloid \
+ yes-coreshell yes-dipole yes-fld yes-granular yes-kspace \
+ yes-manybody yes-mc yes-meam yes-misc \
+ $(usex mpi "yes-user-atc" "") \
+ yes-molecule yes-opt yes-peri yes-poems yes-qeq yes-reax \
+ yes-replica yes-rigid yes-shock yes-snap yes-srd \
+ yes-user-eff yes-user-fep \
+ $(usex mpi "yes-user-lb" "") \
+ yes-user-phonon yes-user-sph yes-voronoi yes-xtc )
+
+ for p in ${packages[@]}; do
+ lmp_emake -C src ${p}
+ done
+}
+
+lmp_build_packages() {
+ lmp_emake -C lib/meam -j1 -f Makefile.gfortran
+ lmp_emake -C lib/poems -f Makefile.g++
+ lmp_emake -C lib/reax -j1 -f Makefile.gfortran
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++
+}
+
+lmp_clean_packages() {
+ lmp_emake -C lib/meam -f Makefile.gfortran clean
+ lmp_emake -C lib/poems -f Makefile.g++ clean
+ lmp_emake -C lib/reax -f Makefile.gfortran clean
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++ clean
+}
+
+src_prepare() {
+ # Fix inconsistent use of SHFLAGS.
+ sed -i \
+ -e 's:voronoi_SYSINC\s\+=.*$:voronoi_SYSINC = -I/usr/include/voro++:' \
+ -e 's:voronoi_SYSPATH\s\+=.*$:voronoi_SYSPATH =:' \
+ lib/voronoi/Makefile.lammps || die
+
+ # Fix missing .so name.
+ sed -i \
+ -e 's:SHLIBFLAGS\s\+=\s\+:SHLIBFLAGS = -Wl,-soname,liblammps.so.0 :' \
+ src/MAKE/Makefile.serial || die
+
+ # Fix makefile in tools.
+ sed -i \
+ -e 's:g++:$(CXX) $(CXXFLAGS):' \
+ -e 's:gcc:$(CC) $(CCFLAGS):' \
+ -e 's:ifort:$(FC) $(FCFLAGS):' \
+ tools/Makefile || die
+
+ # Patch python.
+ epatch "${FILESDIR}/lammps-python3-r2.patch"
+ epatch "${FILESDIR}/python-shebang.patch"
+}
+
+src_compile() {
+ # Fix atc...
+ append-cxxflags -I../../src
+
+ # Acticate packages.
+ elog "Activating lammps packages..."
+ lmp_activate_packages
+
+ # STUBS/mpi.c is using '#include <mpi.h>' now instead of '#include
+ # "mpi.h"' which requires an additional '-I.'.
+ append-cxxflags -I.
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ if use static-libs; then
+ # Build static library.
+ elog "Building static library..."
+ lmp_emake -C src mode=lib serial
+ fi
+
+ # Clean out packages (that's not done by the build system with the clean
+ # target), so we can rebuild the packages with -fPIC.
+ elog "Cleaning packages..."
+ lmp_clean_packages
+
+ # The build system does not rebuild the packages with -fPIC, adding flag
+ # manually.
+ append-cxxflags -fPIC
+ append-fflags -fPIC
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ # Build shared library.
+ elog "Building shared library..."
+ lmp_emake -C src mode=shlib serial
+
+ # Compile main executable. The shared library is always built, and
+ # mode=shexe is simply a way to re-use the object files built in the
+ # "shlib" step when linking the executable. The executable is not actually
+ # using the shared library. If we have built the static library, then we
+ # link that into the executable.
+ elog "Linking executable..."
+ if use static-libs; then
+ lmp_emake -C src mode=exe serial
+ else
+ lmp_emake -C src mode=shexe serial
+ fi
+
+ # Compile tools.
+ elog "Building tools..."
+ lmp_emake -C tools binary2txt chain data2xmovie micelle2d
+}
+
+src_install() {
+ use static-libs && newlib.a src/liblammps_serial.a liblammps.a
+ newlib.so src/liblammps_serial.so liblammps.so.0.0.0
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so.0
+ newbin src/lmp_serial lmp
+ dobin tools/binary2txt
+ dobin tools/chain
+ dobin tools/data2xmovie
+ dobin tools/micelle2d
+ # Don't forget to add header files of optional packages as they are added
+ # to this ebuild. There may also be .mod files from Fortran based
+ # packages.
+ insinto "/usr/include/${PN}"
+ doins -r src/*.h lib/meam/*.mod
+
+ local LAMMPS_POTENTIALS="usr/share/${PN}/potentials"
+ insinto "/${LAMMPS_POTENTIALS}"
+ doins potentials/*
+ echo "LAMMPS_POTENTIALS=${EROOT}${LAMMPS_POTENTIALS}" > 99lammps
+ doenvd 99lammps
+
+ # Install python script.
+ use python && python_foreach_impl python_domodule python/lammps.py
+
+ if use examples; then
+ local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+ insinto "${LAMMPS_EXAMPLES}"
+ doins -r examples/*
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/Manual.pdf
+ dohtml -r doc/*
+ fi
+}