summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sec-keys/openpgp-keys-apache-commons-httpclient/openpgp-keys-apache-commons-httpclient-20220903.ebuild')
-rw-r--r--sec-keys/openpgp-keys-apache-commons-httpclient/openpgp-keys-apache-commons-httpclient-20220903.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-apache-commons-httpclient/openpgp-keys-apache-commons-httpclient-20220903.ebuild b/sec-keys/openpgp-keys-apache-commons-httpclient/openpgp-keys-apache-commons-httpclient-20220903.ebuild
new file mode 100644
index 000000000000..2e293460b605
--- /dev/null
+++ b/sec-keys/openpgp-keys-apache-commons-httpclient/openpgp-keys-apache-commons-httpclient-20220903.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used by httpclient.commons.apache.org"
+HOMEPAGE="https://downloads.apache.org/httpcomponents/commons-httpclient/"
+SRC_URI="https://downloads.apache.org/httpcomponents/commons-httpclient/KEYS -> ${P}-KEYS.asc"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - httpclient.commons.apache.org.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}