summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-9.0.87.ebuild')
-rw-r--r--sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-9.0.87.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-9.0.87.ebuild b/sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-9.0.87.ebuild
new file mode 100644
index 000000000000..f31656897925
--- /dev/null
+++ b/sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-9.0.87.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used by tomcat.apache.org"
+HOMEPAGE="https://tomcat.apache.org/download-90.cgi"
+SRC_URI="https://downloads.apache.org/tomcat/tomcat-$(ver_cut 1)/v${PV}/KEYS -> ${P}-KEYS.asc"
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - tomcat-${PV}.apache.org.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}